summaryrefslogtreecommitdiff
path: root/dev-python/wcag-contrast-ratio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/wcag-contrast-ratio
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/wcag-contrast-ratio')
-rw-r--r--dev-python/wcag-contrast-ratio/Manifest3
-rw-r--r--dev-python/wcag-contrast-ratio/wcag-contrast-ratio-0.9-r1.ebuild31
-rw-r--r--dev-python/wcag-contrast-ratio/wcag-contrast-ratio-0.9.ebuild2
3 files changed, 34 insertions, 2 deletions
diff --git a/dev-python/wcag-contrast-ratio/Manifest b/dev-python/wcag-contrast-ratio/Manifest
index e88b9a4ef771..7cc71ba2810b 100644
--- a/dev-python/wcag-contrast-ratio/Manifest
+++ b/dev-python/wcag-contrast-ratio/Manifest
@@ -1,3 +1,4 @@
DIST wcag-contrast-ratio-0.9.gh.tar.gz 3347 BLAKE2B c32765e7011faf9128bd4c53673c4663b972e225e0f7249dd1b9f07b4184ae9ca93116f31de6a0538f04612a72ee1e805b37e1070ae62347508f29df2bbf9ec4 SHA512 70ff827b092cec884ba7e969deb8b5de944844b8d5536669f2c607061fbf569c217cec93268215deb9fdebc041efd992ed0cc89e0da013f9a1be8eeeb420cec5
-EBUILD wcag-contrast-ratio-0.9.ebuild 739 BLAKE2B 192a4e8fadca593b8a5ad6d691e38ce1f8904f9ae8d1756500c175651950444520bf861da570523b20026dcc975aaa10760a418631c7eff7007d995fc2f1f5af SHA512 c31b66d5e02fd009b2daa5545508e711d27161b5a46db56afdcec4d77308487af0b162eda6cc70d051d79a418969882f67b7125e99a87c608eb942e64a74cc9e
+EBUILD wcag-contrast-ratio-0.9-r1.ebuild 748 BLAKE2B 53d61a0e18e49a5b869d09cdf3d6e2b0b11b2c1e539548bf20633abe41d711e4a9a86a3bad95b6fd00a7ad225e77ddc6eaa87d833937ba7cd4e85da783cf1f3e SHA512 9ff8218fb39e9f2d3fe8f722f9bc8feb832e9f0de0050f374365cd42c5723d38f72bde80c9a64e4092b2c3db073db11b93cf33cb099267373a8266fa5af11c5a
+EBUILD wcag-contrast-ratio-0.9.ebuild 744 BLAKE2B e6c372e6692fa2b0d5d623aeddc456c28464711a1bca78ded8f6b7b3642772a3101f6e827183052c516768f4634546ca6ff05961ca9557e503b48d74c001ba88 SHA512 ecdbd27a4debad7ae81ed8b42d0c78cfd509b684082c861aa9e9f8a2e92f206c861a4be656bca81dd3ec09f905d0292b98bc72fd9c5204770a268363b9867097
MISC metadata.xml 416 BLAKE2B 5363613fc828bc1398b25b81947464f6c71a2d972914b14744da29c723493843fd0d949b0070c5af3d67428694b7c7a2b0a40c8884a62e56d9caf3fa8882ed42 SHA512 c416ea13e371d17d90bb2c1362119431eb0241dc89d0be5c003e92604c66125b7a66e5648a179d1c166b2a4e3a990be86e502da621ebca8e7ba560f1b0558f58
diff --git a/dev-python/wcag-contrast-ratio/wcag-contrast-ratio-0.9-r1.ebuild b/dev-python/wcag-contrast-ratio/wcag-contrast-ratio-0.9-r1.ebuild
new file mode 100644
index 000000000000..bd6b2dc29f65
--- /dev/null
+++ b/dev-python/wcag-contrast-ratio/wcag-contrast-ratio-0.9-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="A library for computing contrast ratios, as required by WCAG 2.0"
+HOMEPAGE="
+ https://github.com/gsnedders/wcag-contrast-ratio/
+ https://pypi.org/project/wcag-contrast-ratio/"
+SRC_URI="
+ https://github.com/gsnedders/wcag-contrast-ratio/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest test.py
+}
diff --git a/dev-python/wcag-contrast-ratio/wcag-contrast-ratio-0.9.ebuild b/dev-python/wcag-contrast-ratio/wcag-contrast-ratio-0.9.ebuild
index 5b7af2bad83a..e4f8fa5bfd69 100644
--- a/dev-python/wcag-contrast-ratio/wcag-contrast-ratio-0.9.ebuild
+++ b/dev-python/wcag-contrast-ratio/wcag-contrast-ratio-0.9.ebuild
@@ -17,7 +17,7 @@ SRC_URI="
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
BDEPEND="
test? (