summaryrefslogtreecommitdiff
path: root/dev-python/watchdog
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
commit64e107b9b6058580ff0432107eb37cefb0b2a7d8 (patch)
tree9a44e603e2ae365e2b1fe35ac37f73e830cdee1d /dev-python/watchdog
parent957235cf19a691360c720f7913672adda4258ed0 (diff)
gentoo resync : 22.10.2018
Diffstat (limited to 'dev-python/watchdog')
-rw-r--r--dev-python/watchdog/Manifest2
-rw-r--r--dev-python/watchdog/watchdog-0.9.0.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/watchdog/Manifest b/dev-python/watchdog/Manifest
index 5eee93ff0290..34d2fdb87a08 100644
--- a/dev-python/watchdog/Manifest
+++ b/dev-python/watchdog/Manifest
@@ -1,4 +1,6 @@
DIST watchdog-0.8.3.tar.gz 83154 BLAKE2B d5d0635e83bbcd31544d5ea5811c2f202b0da76bd7a4086e8fc61e3293640e701b04599f95decaa82bee3705dbd6b91ad24b9dbd20edcfc329913600c8a3c932 SHA512 61f1db886e8e9a6d78b569329f4d5944c296778a5a34f94fbf115a748fb4c3be422bf4d3cc828e22fcdcd380fdf9009f5bd91a8a5edc87089afc58297a0b946f
+DIST watchdog-0.9.0.tar.gz 90597 BLAKE2B 4b83061f49204f13ccdb129c31bd53af256e5541d7a3f6452e59682ab64f37dc2a38e9a82ddcc2cec0ed5c52baed27d62b2fab7eebe2433d924209860b5d4a00 SHA512 97fca2642209150a611d931d6f2049a9941a3494a6c566bc18eaa45a8fc2fbd02c712b37a85cc1375eeb65715706ba6b8ecf781b99951721988c318f81eff7c6
EBUILD watchdog-0.8.3-r1.ebuild 856 BLAKE2B 9c906c5c618f0f2649cffbd79e5b289108ded726af922a3e649d3fe82bf320943409fff5e7dcfee1d0a5028c799bdf41ca6b593019fe02776b1cdcfa08091f02 SHA512 023d639b51945dca4f7b42e439b3f2e4844f1f6d22c49ef91182bc2b899947b133c1703ad0ecfd35f7e519d724ba77cb635102871b8c08514a2ed4cfc23794e8
EBUILD watchdog-0.8.3-r2.ebuild 858 BLAKE2B dc7e530619d92bfcab4dfe9bc8cf0bc94a765e3f27338821e80f5b21bd913a8cd22fb6858da670457d40ee639f5adef0e6d41e909ad7442bcaf857f4cac6d601 SHA512 6dd41c3cd891db711b7367f16d1d22d03054394b6df014933c46aeb19ac6429997d9145c2f0dfc10ada82ab04a0ba9a1aaeca785a538d0f221761b1f7b63b3d5
+EBUILD watchdog-0.9.0.ebuild 933 BLAKE2B ec70f6fe2655e848b8bb5eaf8f92b2f8a3054591aa09c2bb6af63febabcaa56f3416d5279fde7305a3cbdbbfd92291411415e2140c9f744186cdddc802150bf5 SHA512 f9f75235ea8490d63808a3cdd31d6821881011ea4135b1ec0f4e2fedf21ac65a98f48feb2dc063d8a9a8caa582a775f15312dc7d64e3c897419b5e30af576cc7
MISC metadata.xml 384 BLAKE2B 4aa02b5d26bb82f0f0ef9d7369f984114d6b0de77f662ec150e6433324f4500b5b5004b626e7ce3558dc1190a31cbe788793ddbeab4a10f13d2b9be5de36e77e SHA512 0883ee5d6169f36b061be829e7b2e4a69f7efada9f7a2b446a9baad15c8e119d24a7bb3d80bf253a760332bfb8a03ef06b3bc91cb97b7a86d0773252fbc3db90
diff --git a/dev-python/watchdog/watchdog-0.9.0.ebuild b/dev-python/watchdog/watchdog-0.9.0.ebuild
new file mode 100644
index 000000000000..127d55400038
--- /dev/null
+++ b/dev-python/watchdog/watchdog-0.9.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy)
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Python API and shell utilities to monitor file system events"
+HOMEPAGE="https://github.com/gorakhargosh/watchdog"
+SRC_URI="https://github.com/gorakhargosh/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="test"
+
+CDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ dev-python/argh[${PYTHON_USEDEP}]
+ dev-python/pathtools[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ >=dev-python/pytest-timeout-0.3[${PYTHON_USEDEP}]
+ )"
+
+src_prepare() {
+ default
+ rm tox.ini || die
+}
+
+python_test() {
+ pytest -vv || die "Tests failed with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "Bash completion" dev-python/argcomplete
+}