summaryrefslogtreecommitdiff
path: root/dev-python/watchdog/watchdog-3.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-22 00:41:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-22 00:41:01 +0000
commit23b767af73549eeb4dd3069e09d0f2fcb88669a8 (patch)
tree7ad731ac748d72a48ae7079bc8fb0718c554d65d /dev-python/watchdog/watchdog-3.0.0.ebuild
parent3003897133b1bcfe9a241c2708e938903879aee3 (diff)
gentoo auto-resync : 22:03:2023 - 00:41:01
Diffstat (limited to 'dev-python/watchdog/watchdog-3.0.0.ebuild')
-rw-r--r--dev-python/watchdog/watchdog-3.0.0.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/watchdog/watchdog-3.0.0.ebuild b/dev-python/watchdog/watchdog-3.0.0.ebuild
new file mode 100644
index 000000000000..a40cce8f861b
--- /dev/null
+++ b/dev-python/watchdog/watchdog-3.0.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="Python API and shell utilities to monitor file system events"
+HOMEPAGE="
+ https://github.com/gorakhargosh/watchdog/
+ https://pypi.org/project/watchdog/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/pytest-timeout-0.3[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e '/--cov/d' -i setup.cfg || die
+ default
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # known flaky
+ tests/test_emitter.py::test_close
+ # requires root powers via sudo (yes, seriously)
+ tests/test_inotify_buffer.py::test_unmount_watched_directory_filesystem
+ )
+
+ epytest -p no:django
+}
+
+pkg_postinst() {
+ optfeature "Bash completion" dev-python/argcomplete
+}