summaryrefslogtreecommitdiff
path: root/dev-python/watchdog/watchdog-2.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-24 12:10:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-24 12:10:02 +0100
commit0ed86cb810f23bc360b9f8b955903db4e6595244 (patch)
tree7eb8d293be0f1777854714006cde9d7839450a2e /dev-python/watchdog/watchdog-2.3.1.ebuild
parentb46286b28de30f0898fa7888ae7dee09db822088 (diff)
gentoo auto-resync : 24:04:2023 - 12:10:01
Diffstat (limited to 'dev-python/watchdog/watchdog-2.3.1.ebuild')
-rw-r--r--dev-python/watchdog/watchdog-2.3.1.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-python/watchdog/watchdog-2.3.1.ebuild b/dev-python/watchdog/watchdog-2.3.1.ebuild
deleted file mode 100644
index 14e70cce80f3..000000000000
--- a/dev-python/watchdog/watchdog-2.3.1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-
-inherit distutils-r1 optfeature pypi
-
-DESCRIPTION="Python API and shell utilities to monitor file system events"
-HOMEPAGE="
- https://github.com/gorakhargosh/watchdog/
- https://pypi.org/project/watchdog/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- dev-python/pyyaml[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- >=dev-python/pytest-timeout-0.3[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- sed -e '/--cov/d' -i setup.cfg || die
- default
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # known flaky
- tests/test_emitter.py::test_close
- # requires root powers via sudo (yes, seriously)
- tests/test_inotify_buffer.py::test_unmount_watched_directory_filesystem
- )
-
- epytest -p no:django
-}
-
-pkg_postinst() {
- optfeature "Bash completion" dev-python/argcomplete
-}