summaryrefslogtreecommitdiff
path: root/dev-python/watchdog/watchdog-0.10.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-python/watchdog/watchdog-0.10.4.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-python/watchdog/watchdog-0.10.4.ebuild')
-rw-r--r--dev-python/watchdog/watchdog-0.10.4.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/watchdog/watchdog-0.10.4.ebuild b/dev-python/watchdog/watchdog-0.10.4.ebuild
new file mode 100644
index 000000000000..44f305c9f08e
--- /dev/null
+++ b/dev-python/watchdog/watchdog-0.10.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python API and shell utilities to monitor file system events"
+HOMEPAGE="https://github.com/gorakhargosh/watchdog"
+SRC_URI="https://github.com/gorakhargosh/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+
+CDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ dev-python/argh[${PYTHON_USEDEP}]
+ dev-python/pathtools[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ test? (
+ >=dev-python/pytest-timeout-0.3[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/--cov/d' setup.cfg || die
+ # broken when django is installed
+ sed -i -e 's:test_eventlet_monkey_patching:_&:' \
+ tests/test_skip_repeats_queue.py || die
+ default
+}
+
+pkg_postinst() {
+ optfeature "Bash completion" dev-python/argcomplete
+}