summaryrefslogtreecommitdiff
path: root/dev-python/wand/wand-0.6.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /dev-python/wand/wand-0.6.6.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'dev-python/wand/wand-0.6.6.ebuild')
-rw-r--r--dev-python/wand/wand-0.6.6.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/wand/wand-0.6.6.ebuild b/dev-python/wand/wand-0.6.6.ebuild
new file mode 100644
index 000000000000..7c72b4e84647
--- /dev/null
+++ b/dev-python/wand/wand-0.6.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+
+inherit distutils-r1
+
+MY_P="${PN^}-${PV}"
+DESCRIPTION="Ctypes-based simple ImageMagick binding for Python"
+HOMEPAGE="http://wand-py.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="media-gfx/imagemagick"
+BDEPEND="
+ test? (
+ media-gfx/imagemagick[fftw,jpeg,png,truetype,xml]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_test() {
+ # PDF support is blocked by the default ImageMagick security policy
+ pytest -vv --skip-pdf || die "Tests fail with ${EPYTHON}"
+}