summaryrefslogtreecommitdiff
path: root/dev-python/vpython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/vpython
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/vpython')
-rw-r--r--dev-python/vpython/Manifest3
-rw-r--r--dev-python/vpython/metadata.xml16
-rw-r--r--dev-python/vpython/vpython-7.4.2.ebuild20
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/vpython/Manifest b/dev-python/vpython/Manifest
new file mode 100644
index 000000000000..088ff1d431e0
--- /dev/null
+++ b/dev-python/vpython/Manifest
@@ -0,0 +1,3 @@
+DIST vpython-7.4.2.tar.gz 3960161 BLAKE2B e5a0d441f350af1b3390bea943fe5a5a9083234c415b93bf10bbc8109eb280050b447c95e93c18549f5c74a8c3ae43dfe6817cdc4055e4a8a7ad7f66b54c5342 SHA512 dd4db13743f733ac0bfcaac5520da193df9c0f7fc6198f1d55723e45a6e39f642f09f66a3f217669e70027a30c2f8426c0a80bee0d4cbc33b77ac5c927c7e3d0
+EBUILD vpython-7.4.2.ebuild 637 BLAKE2B e8e5ad015c58e8e19a837175128590770034ce5dd7b3d6343f3564c84e6d5d639dfd0a1464f9b1594a8f58802c1e0ae4115b863254010a02208ee53496b106a3 SHA512 5609cebe41dc502215d03222b234fc5f66ed105a78887d32ad196e2a324672e71d2a20b962e62b25c69acbf6fc53897782dd55634f440ceef8e110596f47b950
+MISC metadata.xml 621 BLAKE2B 9b76c9b14bafc55ba1e99bf584a43ebc4414183230809eae1994db3cf10b35e8d7591db002828c9a18e25c73c55183a0a27812d4b6491d282c2229bf17761733 SHA512 fa384102ed51e900a7b27be256688c2fe94cb9e08f5240f116ad3ee4b2581e47b2956efb6446de448554718311e212dde2eecedb5c9ecd01a59dff7e2f14eacc
diff --git a/dev-python/vpython/metadata.xml b/dev-python/vpython/metadata.xml
new file mode 100644
index 000000000000..824d6a7836bd
--- /dev/null
+++ b/dev-python/vpython/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ This package enables one to run VPython in a browser,
+ using the GlowScript VPython API,
+ documented in the Help at http://glowscript.org.
+ If the code is in a cell in a Jupyter notebook,
+ the 3D scene appears in the Jupyter notebook.
+ If the code is launched outside a notebook (e.g. from the command line),
+ a browser window will open displaying the scene.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/vpython/vpython-7.4.2.ebuild b/dev-python/vpython/vpython-7.4.2.ebuild
new file mode 100644
index 000000000000..242bea8fdc7c
--- /dev/null
+++ b/dev-python/vpython/vpython-7.4.2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="VPython for Jupyter notebook"
+HOMEPAGE="http://www.vpython.org/ https://pypi.org/project/vpython/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+DEPEND="dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/versioneer[${PYTHON_USEDEP}]
+ dev-python/jupyter[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/autobahn[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"