summaryrefslogtreecommitdiff
path: root/dev-python/vpython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-python/vpython
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-python/vpython')
-rw-r--r--dev-python/vpython/Manifest3
-rw-r--r--dev-python/vpython/files/vpython-7.6.2-fix-python310-detection.patch56
-rw-r--r--dev-python/vpython/vpython-7.6.2.ebuild38
3 files changed, 97 insertions, 0 deletions
diff --git a/dev-python/vpython/Manifest b/dev-python/vpython/Manifest
index b50be4a456bc..71372f9e37f1 100644
--- a/dev-python/vpython/Manifest
+++ b/dev-python/vpython/Manifest
@@ -1,3 +1,6 @@
+AUX vpython-7.6.2-fix-python310-detection.patch 1871 BLAKE2B 8c9a0a818fd0a8ea9ddc2f5f149c14cf17d691f928badcca8c05a643f7f40eed2b6a2f0c0dbdac0831a02e5acfd93108589db5e5ab9bbc0651915a0ede6138ff SHA512 d5b08fcc87a6dd449718dc848174a24f321582a57b582c78eb35427daf57a023420a0935b8bab9b97dd3c2b2397efffa1956def749acf978f616b8c52aa93b9f
DIST vpython-7.6.1.tar.gz 3552831 BLAKE2B 78281ebbdae2bf09d139569cd344f32aa77aad59ce988a72c57b9984774bc376348c6e69c9119822fe1fbd5dbe6cecf81f17da3977b257c64321e4d4f2deb755 SHA512 8a06bf41865a6bb61c6616c853889b24128f32a9ce1eb8cd9ff861e4995f700ea24e7ffc04fd1edf9cd823a1a592083202abecb1373d5f544facc8646f0cf30b
+DIST vpython-7.6.2.tar.gz 4461606 BLAKE2B 67e59d5ac8e061ffa62433bcc1c3285cf659482e298b706d2b59ef8160c154c42efa8677fce19856a88024af06fb71882ff280ba2e1312a18da272168a4eb1a9 SHA512 fb8f0e9219950cab6d800a44a7fa473bd39e67895170b5cd7636a78cefd83f740d5b4da245b3f252402bfae6e576948b5831d230bf365ac7141ba6bf5f1ef6d6
EBUILD vpython-7.6.1-r3.ebuild 668 BLAKE2B ddf9e620a85b5425427c348a35642877552b1270ae2994364d7e3e8bd5950aaa0c96f17d77ca715b18283154d0b938805971ea7d2d86fbae8375dafe10c40286 SHA512 160cf59afcc603ca7a179b82a3cc19a8528561a52f9ddb77877fc3c32d8feacaff74a1db6bd7d7199cf81ab53d23f92b8b580d64c8fd4d1cc7821ecac155d709
+EBUILD vpython-7.6.2.ebuild 913 BLAKE2B a7ab6b22924c8826a74952eccb9a0a4ed5372bd06e200374c7a54fd677bbfabe228c07a8d14987dbae079f7cc0341a38110e1faba3161fd5aa6b9d7e9ca2bbdb SHA512 1a19852780c7dea1363893eb54d980d9e2d08b8d15c748cdb99be215ef263ad3141c562f34d133b2638a8a81752c87dbd5ab4e252c362444e379ce6b618e941c
MISC metadata.xml 692 BLAKE2B 9d50f8574b424825510b3a5ab1d0af7c5b7a8cb2abaf699605072ffca67f5d8dcf3975ac9762a31d3119f3372df502e5a79ee85653651e0608e0c52b36689b08 SHA512 49f136a4433c864ddc17cf2cb4662866514afd66efe96721dc3c25f26d483cd9c30a327ebcb722867da94356d3a8fbcd62f84c776388fe33b67d913dfbe3a3d4
diff --git a/dev-python/vpython/files/vpython-7.6.2-fix-python310-detection.patch b/dev-python/vpython/files/vpython-7.6.2-fix-python310-detection.patch
new file mode 100644
index 000000000000..5cf5b2fe000a
--- /dev/null
+++ b/dev-python/vpython/files/vpython-7.6.2-fix-python310-detection.patch
@@ -0,0 +1,56 @@
+From 426eeae74eb67934bf7ddcffc07677d93a7ea191 Mon Sep 17 00:00:00 2001
+From: Mike <Axe319@gmail.com>
+Date: Fri, 8 Oct 2021 17:22:52 -0400
+Subject: [PATCH 1/2] Fixed version check to encompass Python 3.10
+
+---
+ vpython/__init__.py | 12 ++++++------
+ 1 file changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/vpython/__init__.py b/vpython/__init__.py
+index 3fc6ce5..c09f697 100644
+--- a/vpython/__init__.py
++++ b/vpython/__init__.py
+@@ -10,14 +10,14 @@
+ # both of those.
+
+ from ._notebook_helpers import _isnotebook, __is_spyder
+-import platform
+-__p = platform.python_version()
++import sys
++__v = sys.version_info
+
+-# Delete platform now that we are done with it
+-del platform
++# Delete sys now that we are done with it
++del sys
+
+-__ispython3 = (__p[0] == '3')
+-__require_notebook = (not __ispython3) or (__p[2] < '5') # Python 2.7 or 3.4 require Jupyter notebook
++__ispython3 = (__v.major == 3)
++__require_notebook = (not __ispython3) or (__v.minor < 5) # Python 2.7 or 3.4 require Jupyter notebook
+
+ if __require_notebook and (not _isnotebook):
+ s = "The non-notebook version of vpython requires Python 3.5 or later."
+
+From 405062dcca5a9a8656b99afb52cd13ce885f8bd1 Mon Sep 17 00:00:00 2001
+From: Mike <Axe319@gmail.com>
+Date: Mon, 11 Oct 2021 18:16:50 -0400
+Subject: [PATCH 2/2] Added username to contributors.md
+
+---
+ CONTRIBUTORS.md | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/CONTRIBUTORS.md b/CONTRIBUTORS.md
+index 1f627bd..d608966 100644
+--- a/CONTRIBUTORS.md
++++ b/CONTRIBUTORS.md
+@@ -30,6 +30,7 @@ We are certain the list is incomplete; please let one of us know by opening an [
+ + Kyle Dunn ([@kdunn926](https://github.com/kdunn926))
+ + Brian Su ([@brianbbsu](https://github.com/brianbbsu))
+ + [@0dminnimda](https://github.com/0dminnimda)
+++ Mike Miller ([@Axe319](https://github.com/axe319))
+
+ ## Full timeline of vpython development
+
diff --git a/dev-python/vpython/vpython-7.6.2.ebuild b/dev-python/vpython/vpython-7.6.2.ebuild
new file mode 100644
index 000000000000..cbf767586bd9
--- /dev/null
+++ b/dev-python/vpython/vpython-7.6.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="VPython for Jupyter notebook"
+HOMEPAGE="https://www.vpython.org/ https://pypi.org/project/vpython/"
+SRC_URI="https://github.com/${PN}/${PN}-jupyter/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-jupyter-${PV}"
+
+RDEPEND="
+ >=dev-python/autobahn-18.8.2[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/jupyter[${PYTHON_USEDEP}]
+ dev-python/jupyter-server-proxy[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/versioneer[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ ${BDEPEND}
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT="test"
+PATCHES="${FILESDIR}/${P}-fix-python310-detection.patch"
+
+distutils_enable_tests pytest