summaryrefslogtreecommitdiff
path: root/dev-python/virtualenvwrapper
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/virtualenvwrapper
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/virtualenvwrapper')
-rw-r--r--dev-python/virtualenvwrapper/Manifest5
-rw-r--r--dev-python/virtualenvwrapper/metadata.xml11
-rw-r--r--dev-python/virtualenvwrapper/virtualenvwrapper-4.7.1.ebuild41
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/virtualenvwrapper/Manifest b/dev-python/virtualenvwrapper/Manifest
new file mode 100644
index 000000000000..8a879058e22c
--- /dev/null
+++ b/dev-python/virtualenvwrapper/Manifest
@@ -0,0 +1,5 @@
+DIST virtualenvwrapper-4.7.1.tar.gz 89930 SHA256 3bf73ede42a689adeedc8ac85662cb539665d3d029459bc8d3e6835ecd81ffde SHA512 f972179992728b8b600388b34562fa9de355f526e4ee25ea88840700a57f196a60eba91ac3137e7d826925c7a8ade7479af383bcbfb8b9b837d0a374b8b3c4fd WHIRLPOOL c56cab31ec89b8dd5bfeb7949f72b2d5c5e6f40543bc7fa960b03edcc9d3c2ec095335eecf0b40adcc0fd1c92efc1e760748db772a3da0c44591ed7de5248880
+EBUILD virtualenvwrapper-4.7.1.ebuild 1038 SHA256 64d9b7b5e73bf10f727dfe1be8edbbc14019c2689f4df788f97a3d0849555325 SHA512 a5c1db1843a440cf3069dd32d1a7fe0b4335be16cb8f38cc6c8832105ff43741a76445195c27479187edb7538d1b55a7cef1ad0bae39a7435c3d032dccf59de8 WHIRLPOOL 242ca1320fdbb4924905f7e798e2ea32845e18a7935c997d7aac3e0782a1c9de8f14db3fe1b4bcf96c20222cbcdd9027054b9a9f814d3a06754613a96da0427a
+MISC ChangeLog 3946 SHA256 41858a5aafb5e766d362c248f9f29eb792226affd33529227bb42515aacb8a97 SHA512 717dab7e0b358ebd7c59b863b11e69a3e79c24c837b9ca92b8478e2ab745ff56a9ad1754c48c3d1527c6b59bd7db99a1f973f871e451760917360b45096547fe WHIRLPOOL 70b9f145449c49a095d138f8771aaa8db30a02cc166cdd86e6ab84b16c47dc928c9b0498c6da29f94bf00a7db9bfc56e690fb2a6732e15e74e6436f0cbf275d1
+MISC ChangeLog-2015 3582 SHA256 66984f21344d3987ae7e3a9f463c49ae31f9f46c59e60cbb083e5c3efa2c8478 SHA512 0730aa4399704f0eea24b4daf873cc9814308fdb489a247687fc2029e63074b347be6ce1b622a5bad883a010d224891415cd577ee40868a67f090b6e7c8032cb WHIRLPOOL e7fc9f261d6cdfbde6fb8249bcae91276a1be731f642aecef5d02d20a79c383aa789da001eb405918745a21b7a7e03f965dbee23051a85a0de5f3de90de8497d
+MISC metadata.xml 320 SHA256 d50761613945142dc09c471e00cc207cccee654ccb36f5b96fc52bc9256a680d SHA512 dd5556b6b8cc96882032b3b00de65e2ca95cc0ee93c00639f1537e4abd31cc14022e2b61cb04f12b53480c273ef9be269128c4b683a9774590b1cdd552582386 WHIRLPOOL e153fca5cb0253cd196bc416e38c2fc3252704c8a810de41a80bf5c2ba521a3844ebc6f9b61438de62bedc0847c8e7cbf5ff3c45ecca778ea194b798f219b0e5
diff --git a/dev-python/virtualenvwrapper/metadata.xml b/dev-python/virtualenvwrapper/metadata.xml
new file mode 100644
index 000000000000..1c5324be401f
--- /dev/null
+++ b/dev-python/virtualenvwrapper/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">virtualenvwrapper</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/virtualenvwrapper/virtualenvwrapper-4.7.1.ebuild b/dev-python/virtualenvwrapper/virtualenvwrapper-4.7.1.ebuild
new file mode 100644
index 000000000000..6e8c82709c56
--- /dev/null
+++ b/dev-python/virtualenvwrapper/virtualenvwrapper-4.7.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Set of extensions to Ian Bicking's virtualenv tool"
+HOMEPAGE="
+ http://www.doughellmann.com/projects/virtualenvwrapper
+ https://pypi.python.org/pypi/virtualenvwrapper"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+# testsuite doesn't work out of the box. Demand of a virtualenv outstrips setup by the eclass
+RESTRICT=test
+
+RDEPEND="
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-0.15-r1[${PYTHON_USEDEP}]
+ dev-python/virtualenv-clone[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]"
+
+# Keep just in case
+python_prepare_all() {
+ sed -e 's:-o shwordsplit::' -i tests/run_tests || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ bash ./tests/run_tests || die "Tests failed under ${EPYTHON}"
+}