summaryrefslogtreecommitdiff
path: root/dev-python/virtualenv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
commitebc282ef4dfa408accac685565b8ee5f6faec119 (patch)
treec0a4f713228cda0ab17eed46f0bb7ca8cb8be2f6 /dev-python/virtualenv
parent6c8694a707151d59555b0e4e48235f085ce166c3 (diff)
gentoo auto-resync : 12:02:2023 - 09:56:54
Diffstat (limited to 'dev-python/virtualenv')
-rw-r--r--dev-python/virtualenv/Manifest2
-rw-r--r--dev-python/virtualenv/virtualenv-20.19.0.ebuild108
2 files changed, 110 insertions, 0 deletions
diff --git a/dev-python/virtualenv/Manifest b/dev-python/virtualenv/Manifest
index 9984298a2352..acf580fbd7d6 100644
--- a/dev-python/virtualenv/Manifest
+++ b/dev-python/virtualenv/Manifest
@@ -1,5 +1,7 @@
DIST virtualenv-20.17.1.tar.gz 12269737 BLAKE2B 5caa223d549ecb69de3a17dec84a608f34f01c5abd39ab478c27438f71e36e6878a719f9002464dbf0f335bc90a2f4552e201d59e0e757fabef6f3caaaf857fb SHA512 6b32145f431f6b1f4c2a2ed888e8b9e5cb941e04ea1e68830053dceac80ee8bbf2286c1f353951d50d4b8417b8d81ee4b30dae597c94f2a3baf50f174f7ef4d4
DIST virtualenv-20.18.0.tar.gz 12063086 BLAKE2B 272957077dd0a5868e8979c7c34bda1ae28af857d1d5bbafeef6955bcf44a7c5d38f4f131b57a2593180ffdc5a034b18998ba3e4307b7191ebafccc80ef46278 SHA512 b02533878b8d8859f10b51dbdb9fecddf9b49aa2cf1437ddc10cadba82e5361fdeb8b8c94efcc3c8268ddecef31651c28c213e87588aa917479e8d0e2e823493
+DIST virtualenv-20.19.0.tar.gz 12063084 BLAKE2B 6a6d94c7099aa841523909173b04821697c7fc8b284325dbf191f6b2184bce19802924e0a001267448a785c35f8bbd7cee74f7514a375e4e47a9d3275404f756 SHA512 75c63fea11ad070985cb2ba17adfcb7e1739e8798b80919cc17a527d7180f68a04197436b44146cd07423d8d2e4982d1716b0e18159add5ce6a748b31f6b2776
EBUILD virtualenv-20.17.1.ebuild 4921 BLAKE2B 111ebcd11762d03f508c46e5426c7a5658561763b5e7c75fbb40e34a5346a945702f15958a924b28e53917f48e69f7680eb925fd8f4b128d2d7173ddde739cdb SHA512 c95bbbb078c781001fc5a095c9e4c675c79a6fa721a770ccae7030a224aa84ec2488c69f910c848201478f4e00e7249fb1cd47a202d9f14d6b023bd5d2a3e3c7
EBUILD virtualenv-20.18.0.ebuild 5012 BLAKE2B a9a7eea77d19e51ee9bd8be50e317c74f479ccca741bbc2f548b8e3942f56a72e9e6ebf9801bcce4ecbb0044fb9eda99ce2f8a54cc1312a00c08b14bcf37897f SHA512 e1d23175eb0b799583329894e794ceb5a2527974bf35fd5c55d68115febff456e7a2c748869994cc841fc9d9b4f6e032821652cb2a0a54eb959cbf55046e1a6d
+EBUILD virtualenv-20.19.0.ebuild 4956 BLAKE2B 8d2e8d581d4e8f625483d80cc5c3b5a8c494ddaae3779ba88591b16528f53ffa8648156ac6175070930959c7d855418daeaad08ff5f8eb92371bf505a7da2229 SHA512 db8c693376671a7ef18d00ef468bfa67e37afb0467e584316543c1efc8c7c4e22fba61bfbaa9e8805aca9db2e26a58977c7ab3aad41f7e98bcd3678a9ae6b7b3
MISC metadata.xml 406 BLAKE2B 97fee04c2662c5c36b6e16538284def46eb2454424770f42edf2567ed804ca15c4e969c714c57573f897b0946246577ab6e35204ed1f3f1735713d8ab5d24667 SHA512 356d42db463b63a3b3a55c1e98eb661de0a10aa6a5fde4f8b3f888ec73020c6679e86efd8dbb0b3e4a5a720af95e658612ba460fe548e081a90beec75fb9c1b2
diff --git a/dev-python/virtualenv/virtualenv-20.19.0.ebuild b/dev-python/virtualenv/virtualenv-20.19.0.ebuild
new file mode 100644
index 000000000000..23d33288f6bb
--- /dev/null
+++ b/dev-python/virtualenv/virtualenv-20.19.0.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Virtual Python Environment builder"
+HOMEPAGE="
+ https://virtualenv.pypa.io/en/stable/
+ https://pypi.org/project/virtualenv/
+ https://github.com/pypa/virtualenv/
+"
+
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+
+RDEPEND="
+ <dev-python/distlib-1[${PYTHON_USEDEP}]
+ >=dev-python/distlib-0.3.6[${PYTHON_USEDEP}]
+ <dev-python/filelock-4[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.4.1[${PYTHON_USEDEP}]
+ <dev-python/platformdirs-4[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.4[${PYTHON_USEDEP}]
+"
+# coverage is used somehow magically in virtualenv, maybe it actually
+# tests something useful
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ >=dev-python/pip-22.2.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-freezegun-0.4.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.6.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-timeout-2.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
+ )
+"
+
+# (unpackaged deps)
+#distutils_enable_sphinx docs \
+# dev-python/sphinx-argparse \
+# dev-python/sphinx_rtd_theme \
+# dev-python/towncrier
+distutils_enable_tests pytest
+
+src_configure() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ tests/unit/activation/test_xonsh.py
+ tests/unit/seed/embed/test_bootstrap_link_via_app_data.py::test_seed_link_via_app_data
+ tests/unit/create/test_creator.py::test_cross_major
+ # tests failing without python2 installed
+ "tests/unit/create/test_creator.py::test_py_pyc_missing[True-False]"
+ "tests/unit/create/test_creator.py::test_py_pyc_missing[False-False]"
+ )
+ [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
+ 'tests/unit/create/test_creator.py::test_create_no_seed[root-pypy3-posix-copies-isolated]'
+ 'tests/unit/create/test_creator.py::test_create_no_seed[root-pypy3-posix-copies-global]'
+ 'tests/unit/create/test_creator.py::test_create_no_seed[venv-pypy3-posix-copies-isolated]'
+ 'tests/unit/create/test_creator.py::test_create_no_seed[venv-pypy3-posix-copies-global]'
+ 'tests/unit/create/test_creator.py::test_create_no_seed[root-venv-copies-isolated]'
+ 'tests/unit/create/test_creator.py::test_create_no_seed[root-venv-copies-global]'
+ 'tests/unit/create/test_creator.py::test_create_no_seed[venv-venv-copies-isolated]'
+ 'tests/unit/create/test_creator.py::test_create_no_seed[venv-venv-copies-global]'
+ 'tests/unit/create/test_creator.py::test_zip_importer_can_import_setuptools'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7.9-64-bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7.9--bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7.10-64-bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7.10--bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7-64-bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7--bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3-64-bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3--bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7.9-64-bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7.9--bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7.10-64-bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7.10--bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7-64-bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7--bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3-64-bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3--bin-]'
+ )
+ [[ ${EPYTHON} == python3.11 ]] && EPYTEST_DESELECT+=(
+ # TODO
+ tests/unit/discovery/py_info/test_py_info.py::test_py_info_setuptools
+ tests/unit/discovery/py_info/test_py_info.py::test_custom_venv_install_scheme_is_prefered
+ tests/unit/discovery/py_info/test_py_info.py::test_fallback_existent_system_executable
+ )
+
+ epytest
+}
+
+pkg_postinst() {
+ elog "Please note that while virtualenv package no longer supports"
+ elog "Python 2.7, you can still create py2.7 virtualenvs via:"
+ elog " $ virtualenv -p 2.7 ..."
+}