summaryrefslogtreecommitdiff
path: root/dev-python/virtualenv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-22 00:03:23 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-22 00:03:23 +0100
commitd3bd579653c6e5f8e1c0a36517372a262ade6c8d (patch)
tree7078b1e6375421ced0dbdd93a81dee1c6a3e04a3 /dev-python/virtualenv
parentebd51986f51b430f84c569c6c0f2fe051158d444 (diff)
gentoo auto-resync : 22:04:2023 - 00:03:23
Diffstat (limited to 'dev-python/virtualenv')
-rw-r--r--dev-python/virtualenv/Manifest2
-rw-r--r--dev-python/virtualenv/virtualenv-20.22.0.ebuild101
2 files changed, 103 insertions, 0 deletions
diff --git a/dev-python/virtualenv/Manifest b/dev-python/virtualenv/Manifest
index 6017edaf98c2..b1cd8860cea4 100644
--- a/dev-python/virtualenv/Manifest
+++ b/dev-python/virtualenv/Manifest
@@ -1,5 +1,7 @@
DIST virtualenv-20.20.0.tar.gz 12069625 BLAKE2B 3db53d2859c542953be233af0d195d992eecef345700ad7c229b88519f7042189907263d312d3613b45c5c069bec2440a8639bcc58b2c6894ed79301735e65b2 SHA512 6710efcbead1358479961c84ec3f6b9c3a1fc59c2f6b33fa13e2609554f7072aee7ef8cc07b4aa2fbc27ac950a78e447529fb8ceb2e4ee0881a4356a67d26641
DIST virtualenv-20.21.0.tar.gz 12070063 BLAKE2B f69d5934191ccd8e9420c37e51b53df7876961d6f13d0f75845530893fd91df29a512e64eaa27135535816250a3149087029e6fe1b15317b8079af9cee2832ea SHA512 77aae5ebc5007093953c30da1eed996e851a65c7dd1f7a3a85961a1bb251b3d7970936eea1efe8babb216d2024072bdbf1c1a97ba8760a04a0abf6e7c3a27d09
+DIST virtualenv-20.22.0.tar.gz 6612036 BLAKE2B aeebf0a80dd96eb78dc4a2ca258e1089a9ce1a4e0bb66b1e8b5093353e298e22dbcc57acea7f5094dee29e4e855c51ce235901fd39d29fbfbc3dd96dcef8b15f SHA512 83d15b03abebd856b1636d0f00443f77882de9fdeb9dff67b72dc839d55f4e7e0668914ef3ac79cdf1d8cf147e29ba97feb720a5ebfcf24dc6cd27ec2e04384d
EBUILD virtualenv-20.20.0.ebuild 4761 BLAKE2B 75819c09d97c7f43d32d2840c67d2a42c71b1218e19dbf327f2cb9c9fb705376384de1b4d071302f3d65b16ed5d0dab9fe4504eb68b07dad8446be8240806244 SHA512 ecdb0b5b5073eff31b43a3fc6879d2df6650dc788b6a82d7e15316b394aba08d2c44ea8f66f0481c3086b4702e2eb7438ed86aaa0b9b780a1355d7a9b15bcf4e
EBUILD virtualenv-20.21.0.ebuild 4769 BLAKE2B b2641b3d910b24c0d5b52ef5a3a4d79b8b7256b2a86cb17994d6ce64f79a4c14103f75ae76d8f4f1426defa853ca884c5da1983685bf2e22cca553408a54e472 SHA512 49ee545c8b6898126d138665f88b3018ebdb6c7f2580b7e8be13626103680f051a61017038f53429f0caf7913265e0092076619c50fd5b12bb593a8e36ab7e9a
+EBUILD virtualenv-20.22.0.ebuild 4753 BLAKE2B ce01c6c59613a1fdd6be8e4e6fd81c3871516553dc3801ea6ced98e359a45ee803ade45f756fee320fe5ae6aad33a2db59283acac7826531f83b47440ab74e1e SHA512 b8f125a03e5a8281ef04a08237a6fcd210d58ee48a036360e427242493aa97d99a810110396e21554f5474fb27bfb8810cfc62a9998641f559864f5ad19e9e76
MISC metadata.xml 406 BLAKE2B 97fee04c2662c5c36b6e16538284def46eb2454424770f42edf2567ed804ca15c4e969c714c57573f897b0946246577ab6e35204ed1f3f1735713d8ab5d24667 SHA512 356d42db463b63a3b3a55c1e98eb661de0a10aa6a5fde4f8b3f888ec73020c6679e86efd8dbb0b3e4a5a720af95e658612ba460fe548e081a90beec75fb9c1b2
diff --git a/dev-python/virtualenv/virtualenv-20.22.0.ebuild b/dev-python/virtualenv/virtualenv-20.22.0.ebuild
new file mode 100644
index 000000000000..3d4999549c4e
--- /dev/null
+++ b/dev-python/virtualenv/virtualenv-20.22.0.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Virtual Python Environment builder"
+HOMEPAGE="
+ https://virtualenv.pypa.io/en/stable/
+ https://pypi.org/project/virtualenv/
+ https://github.com/pypa/virtualenv/
+"
+
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+
+RDEPEND="
+ <dev-python/distlib-1[${PYTHON_USEDEP}]
+ >=dev-python/distlib-0.3.6[${PYTHON_USEDEP}]
+ <dev-python/filelock-4[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.11[${PYTHON_USEDEP}]
+ <dev-python/platformdirs-4[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-3.2[${PYTHON_USEDEP}]
+"
+# coverage is used somehow magically in virtualenv, maybe it actually
+# tests something useful
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ >=dev-python/pip-22.2.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-freezegun-0.4.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.6.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
+ )
+"
+# https://github.com/pypa/virtualenv/issues/2554
+BDEPEND+="
+ test? (
+ $(python_gen_cond_dep '
+ !!<dev-python/virtualenv-20.22[${PYTHON_USEDEP}]
+ ' 3.9)
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ tests/unit/activation/test_xonsh.py
+ tests/unit/seed/embed/test_bootstrap_link_via_app_data.py::test_seed_link_via_app_data
+ tests/unit/create/test_creator.py::test_cross_major
+ # tests failing without python2 installed
+ "tests/unit/create/test_creator.py::test_py_pyc_missing[True-False]"
+ "tests/unit/create/test_creator.py::test_py_pyc_missing[False-False]"
+ )
+ [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
+ 'tests/unit/create/test_creator.py::test_create_no_seed[root-pypy3-posix-copies-isolated]'
+ 'tests/unit/create/test_creator.py::test_create_no_seed[root-pypy3-posix-copies-global]'
+ 'tests/unit/create/test_creator.py::test_create_no_seed[venv-pypy3-posix-copies-isolated]'
+ 'tests/unit/create/test_creator.py::test_create_no_seed[venv-pypy3-posix-copies-global]'
+ 'tests/unit/create/test_creator.py::test_create_no_seed[root-venv-copies-isolated]'
+ 'tests/unit/create/test_creator.py::test_create_no_seed[root-venv-copies-global]'
+ 'tests/unit/create/test_creator.py::test_create_no_seed[venv-venv-copies-isolated]'
+ 'tests/unit/create/test_creator.py::test_create_no_seed[venv-venv-copies-global]'
+ 'tests/unit/create/test_creator.py::test_zip_importer_can_import_setuptools'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7.9-64-bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7.9--bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7.10-64-bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7.10--bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7-64-bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7--bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3-64-bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3--bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7.9-64-bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7.9--bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7.10-64-bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7.10--bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7-64-bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7--bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3-64-bin-]'
+ 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3--bin-]'
+ )
+ [[ ${EPYTHON} == python3.11 ]] && EPYTEST_DESELECT+=(
+ # TODO
+ tests/unit/discovery/py_info/test_py_info.py::test_py_info_setuptools
+ tests/unit/discovery/py_info/test_py_info.py::test_custom_venv_install_scheme_is_prefered
+ tests/unit/discovery/py_info/test_py_info.py::test_fallback_existent_system_executable
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p flaky -p freezegun -p pytest_mock
+}