summaryrefslogtreecommitdiff
path: root/dev-python/virtualenv-clone
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-20 08:08:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-20 08:08:43 +0000
commita332b8e207ac6a51fa349c699b486d870c9cdc70 (patch)
tree533ef6beef6beb1c438f8db09b780aa1b8f5eb3b /dev-python/virtualenv-clone
parentaec90632962b8bc48f23a1b5505d8afa0dfb6943 (diff)
gentoo auto-resync : 20:01:2024 - 08:08:43
Diffstat (limited to 'dev-python/virtualenv-clone')
-rw-r--r--dev-python/virtualenv-clone/Manifest3
-rw-r--r--dev-python/virtualenv-clone/files/virtualenv-clone-0.5.7-backport-pr79.patch28
-rw-r--r--dev-python/virtualenv-clone/virtualenv-clone-0.5.7.ebuild4
3 files changed, 33 insertions, 2 deletions
diff --git a/dev-python/virtualenv-clone/Manifest b/dev-python/virtualenv-clone/Manifest
index dab266b68f5b..654ad1d7ff01 100644
--- a/dev-python/virtualenv-clone/Manifest
+++ b/dev-python/virtualenv-clone/Manifest
@@ -1,3 +1,4 @@
+AUX virtualenv-clone-0.5.7-backport-pr79.patch 1002 BLAKE2B ee91b2ddc7c1d955abc5a8a4cae24033cbaf1c5f0b494ea2f11bf0e5d8c6ac9183c4388a1b36e390be8efb3ec79c7146c454bbeb5734b36d8c90dee4850270d2 SHA512 5941d9db3f443f617433576ba4963e441164217cc0e9afd726c1fa49765cf423c02fec932a859cf8ce6b9edd4ec64e20f8636a1f728b77c2aadacb370d01395b
DIST virtualenv-clone-0.5.7.gh.tar.gz 8749 BLAKE2B 584f67c5a1921667ff2daf3b632ca6661d60ace166c6d05e22783a37c4387a92ec1a97990eb7a0c1a687d3e14d258df54b8b81c560458e33c31657c2c378382a SHA512 a71cc1e02ac70fb41945a505297ae894a0bd17e397f90b7cc9ddff599b2f649ca24d3e767a2672e8c27c387e5a235ec6bcbbfcdeb9a0c6e6d4600cf7f4149f4a
-EBUILD virtualenv-clone-0.5.7.ebuild 635 BLAKE2B 26b3e0af99bf9ad01c33a2735e4b8dbd02283b69869f4cedf27ebf764468bfced07706888efeb9ba4f7ce6e364c3f9e9c8657037c02fea70861096c0ad6b8cc1 SHA512 47bc2fea9ce4dfeee97f7a5261d7df8f93df57d424336a58b4ab20e0447640320ca8416194e6ea41c4f8508aed3ee8427772c2a2d50e36a7b55114483f2d77e6
+EBUILD virtualenv-clone-0.5.7.ebuild 694 BLAKE2B 4569a943e36741506775cc22c0aad8159a2266a615f6aa74225aacee08b2d90c96ad9a039f9ec0f285fbfd40f8b3171d71ef15d0fee20fc259b65308a440ddff SHA512 724512cfcce8164d48d2b74c659fb773eb2d18f80fa66723b68eada79dd825c238a4bfe9ee4c3f6da7bdc02bdf32b0146db52cc85b71ea12f85e6f4f9a59fb7a
MISC metadata.xml 426 BLAKE2B e1f7d7fac506cfd33a89fc1824aecc183c8791629fba4d5dd807042b37b22cac47eec7e4ee8f3cdfc721bbeddb675f8174f97d53f68f64a4ee96370f4b13fa57 SHA512 b3f17e3ad784a814d5107944877612f80353fd0719fdb9875430cc0c327a4b8bf8d62ae9dd5aecaa300b56e2c85d8f8b8ea8b54d1e7d93392a38f0645e1319f2
diff --git a/dev-python/virtualenv-clone/files/virtualenv-clone-0.5.7-backport-pr79.patch b/dev-python/virtualenv-clone/files/virtualenv-clone-0.5.7-backport-pr79.patch
new file mode 100644
index 000000000000..7ded302ed099
--- /dev/null
+++ b/dev-python/virtualenv-clone/files/virtualenv-clone-0.5.7-backport-pr79.patch
@@ -0,0 +1,28 @@
+https://bugs.gentoo.org/918079
+https://github.com/edwardgeorge/virtualenv-clone/pull/79
+
+From 028494ee84cf4626aab291c621b2b9ec23f8688a Mon Sep 17 00:00:00 2001
+From: matoro <matoro@users.noreply.github.com>
+Date: Mon, 18 Dec 2023 18:18:17 -0500
+Subject: [PATCH] Support Python 3.11, 3.12
+
+---
+ .travis.yml | 2 ++
+ setup.py | 2 ++
+ tests/__init__.py | 2 +-
+ tox.ini | 2 +-
+ 4 files changed, 6 insertions(+), 2 deletions(-)
+
+diff --git a/tests/__init__.py b/tests/__init__.py
+index c9a52ca..14648f4 100644
+--- a/tests/__init__.py
++++ b/tests/__init__.py
+@@ -8,7 +8,7 @@
+ tmplocation = tempfile.mkdtemp()
+ venv_path = os.path.realpath(os.path.join(tmplocation,'srs_venv'))
+ clone_path = os.path.realpath(os.path.join(tmplocation,'clone_venv'))
+-versions = ['2.7', '3.4', '3.5', '3.6', '3.7', '3.8', '3.9', '3.10']
++versions = ['2.7', '3.4', '3.5', '3.6', '3.7', '3.8', '3.9', '3.10', '3.11', '3.12']
+
+ def clean():
+ if os.path.exists(tmplocation): shutil.rmtree(tmplocation)
diff --git a/dev-python/virtualenv-clone/virtualenv-clone-0.5.7.ebuild b/dev-python/virtualenv-clone/virtualenv-clone-0.5.7.ebuild
index c3063860f8c8..d1f083f33ab1 100644
--- a/dev-python/virtualenv-clone/virtualenv-clone-0.5.7.ebuild
+++ b/dev-python/virtualenv-clone/virtualenv-clone-0.5.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -28,4 +28,6 @@ BDEPEND="
)
"
+PATCHES=( "${FILESDIR}/${PN}-0.5.7-backport-pr79.patch" )
+
distutils_enable_tests pytest