summaryrefslogtreecommitdiff
path: root/dev-python/vine/vine-5.0.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-17 07:54:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-17 07:54:11 +0100
commit403387a1bc2a2d98e75bf1474b21ae379b88aab2 (patch)
tree3efa95ca1b0ee7a013a85f88134d4cc9d1c4a115 /dev-python/vine/vine-5.0.0-r1.ebuild
parent9126563f8b9bef939e4df502bf0e52f19fc4f444 (diff)
gentoo auto-resync : 17:10:2022 - 07:54:11
Diffstat (limited to 'dev-python/vine/vine-5.0.0-r1.ebuild')
-rw-r--r--dev-python/vine/vine-5.0.0-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/vine/vine-5.0.0-r1.ebuild b/dev-python/vine/vine-5.0.0-r1.ebuild
new file mode 100644
index 000000000000..70d4f44fc673
--- /dev/null
+++ b/dev-python/vine/vine-5.0.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Promises"
+HOMEPAGE="
+ https://github.com/celery/vine/
+ https://pypi.org/project/vine/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # remove the dep on dead dev-python/case package
+ sed -i -e 's:from case:from unittest.mock:' t/unit/*.py || die
+ # also removed upstream
+ rm t/unit/conftest.py || die
+
+ distutils-r1_src_prepare
+}