summaryrefslogtreecommitdiff
path: root/dev-python/venusian/venusian-1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/venusian/venusian-1.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/venusian/venusian-1.0.ebuild')
-rw-r--r--dev-python/venusian/venusian-1.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/venusian/venusian-1.0.ebuild b/dev-python/venusian/venusian-1.0.ebuild
new file mode 100644
index 000000000000..d2f58f4b7e10
--- /dev/null
+++ b/dev-python/venusian/venusian-1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library for deferring decorator actions"
+HOMEPAGE="http://www.pylonsproject.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND="
+ "
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/nose-exclude-0.1.9[${PYTHON_USEDEP}] )"
+
+python_test() {
+ esetup.py nosetests
+}