summaryrefslogtreecommitdiff
path: root/dev-python/vecrec/vecrec-0.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-07 22:48:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-07 22:48:01 +0000
commitc3bc61051d7f12b4c682efa7a5460bbc8815649e (patch)
treeb6d19e96ba3c397fb8278eeb9b68170db92630ba /dev-python/vecrec/vecrec-0.3.1.ebuild
parent3517852e3b8a68d1e997770fc0650c5053bafc6c (diff)
gentoo resync : 07.01.2022
Diffstat (limited to 'dev-python/vecrec/vecrec-0.3.1.ebuild')
-rw-r--r--dev-python/vecrec/vecrec-0.3.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/vecrec/vecrec-0.3.1.ebuild b/dev-python/vecrec/vecrec-0.3.1.ebuild
new file mode 100644
index 000000000000..c784a58d1ffe
--- /dev/null
+++ b/dev-python/vecrec/vecrec-0.3.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="2D vector and rectangle classes"
+HOMEPAGE="https://github.com/kxgames/vecrec
+ https://pypi.org/project/vecrec/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND="dev-python/autoprop[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e '/addopts/d' -i tests/pytest.ini || die
+ sed -e 's/distutils.core/setuptools/' -i setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ epytest tests
+}