summaryrefslogtreecommitdiff
path: root/dev-python/vcrpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-03 13:14:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-03 13:14:46 +0100
commitdd987f40168e0552ca0d36e2cedccceda4a34ecf (patch)
tree8658334e6733160ef7185209b643eaa9e0ba0f0c /dev-python/vcrpy
parentc0f9c483e315379eabfbbef34fad51dbe42c896d (diff)
gentoo auto-resync : 03:10:2022 - 13:14:45
Diffstat (limited to 'dev-python/vcrpy')
-rw-r--r--dev-python/vcrpy/Manifest2
-rw-r--r--dev-python/vcrpy/vcrpy-4.2.0.ebuild58
2 files changed, 0 insertions, 60 deletions
diff --git a/dev-python/vcrpy/Manifest b/dev-python/vcrpy/Manifest
index 731b9a2b33a6..e92497c39cfc 100644
--- a/dev-python/vcrpy/Manifest
+++ b/dev-python/vcrpy/Manifest
@@ -1,5 +1,3 @@
-DIST vcrpy-4.2.0.gh.tar.gz 331096 BLAKE2B dccb9310da42c6f75d0d503cb64aa09876447098bff2ad6a1507a0e0907ce05a89d46ccc159e79f310e027fc8f3075b7474274ad39ca4778acbc6d2a8f633004 SHA512 61eeec585fc78be1ae6d4f9047123c9680611e436bb5980fb7c6b885e16b2ef9bd5ce921efff7e87a222b3662c7009dbf0a8df24cdb9849d09deb24957ba4889
DIST vcrpy-4.2.1.gh.tar.gz 331180 BLAKE2B 345e4c148963e2109d02be4e96986083236bd29fa8049c7cc54483f12d0506cde5c116b6f2fe80e099599b22a73e2f6240f7bb91e4a7d8af7f4e8e741097160d SHA512 59231e5164cda3099b18d099f0ef97e062e6401e52e5dfc4022aa89ca02881e9e6e3c782f12c288f5281b3b3bf175dc33a267bc6d2b40791582a1221f5d7aaab
-EBUILD vcrpy-4.2.0.ebuild 1585 BLAKE2B 4329d7fa8facfd83c46263e1f0e8993204f36e5be316e9e960b5aaa82542fa72e0a176a5c8614ea5a410b58b916658c08ec779f369f2c63232dc4d484db98003 SHA512 68a34453060fde72b1dc7addf00560ec39b1593bee154a67c708b97011969f8485f9d2e104097b658d46efdee6f293d183dab16cd718ebf40686cb4eb509106d
EBUILD vcrpy-4.2.1.ebuild 1585 BLAKE2B 4329d7fa8facfd83c46263e1f0e8993204f36e5be316e9e960b5aaa82542fa72e0a176a5c8614ea5a410b58b916658c08ec779f369f2c63232dc4d484db98003 SHA512 68a34453060fde72b1dc7addf00560ec39b1593bee154a67c708b97011969f8485f9d2e104097b658d46efdee6f293d183dab16cd718ebf40686cb4eb509106d
MISC metadata.xml 388 BLAKE2B fd31293bd6085e6a93816a1813a8c3a9d046ed3d932fba5b32b454a71e7535606ba92815699b7ca10fc837b07a5335df54d5fae8c860a7ea88c6ea72891d0620 SHA512 0360ac6f113035ffd1991d2a42000f290c9d0a3fa8c4dac9abfde0eecafd23e1ff9929d8ee521f83a924c523992fabc5cb4353079bf7c52dac9f906a31d4da55
diff --git a/dev-python/vcrpy/vcrpy-4.2.0.ebuild b/dev-python/vcrpy/vcrpy-4.2.0.ebuild
deleted file mode 100644
index d7b461c16f56..000000000000
--- a/dev-python/vcrpy/vcrpy-4.2.0.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Automatically mock your HTTP interactions to simplify and speed up testing"
-HOMEPAGE="
- https://github.com/kevin1024/vcrpy/
- https://pypi.org/project/vcrpy/
-"
-SRC_URI="
- https://github.com/kevin1024/vcrpy/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-RDEPEND="
- >=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- >=dev-python/six-1.5[${PYTHON_USEDEP}]
- dev-python/urllib3[${PYTHON_USEDEP}]
- dev-python/wrapt[${PYTHON_USEDEP}]
- dev-python/yarl[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pytest-httpbin[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # these tests require Internet
- tests/integration/test_aiohttp.py
- tests/integration/test_boto.py
- tests/integration/test_httplib2.py::test_effective_url
- tests/integration/test_httpx.py
- tests/integration/test_urllib2.py::test_effective_url
- tests/integration/test_urllib3.py::test_redirects
- tests/integration/test_wild.py::test_amazon_doctype
- tests/integration/test_wild.py::test_flickr_should_respond_with_200
- tests/unit/test_stubs.py::TestVCRConnection::testing_connect
- )
-
- local -x REQUESTS_CA_BUNDLE=$("${EPYTHON}" -m pytest_httpbin.certs)
- epytest
-}