summaryrefslogtreecommitdiff
path: root/dev-python/vcrpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /dev-python/vcrpy
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'dev-python/vcrpy')
-rw-r--r--dev-python/vcrpy/Manifest2
-rw-r--r--dev-python/vcrpy/vcrpy-4.0.2.ebuild50
2 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/vcrpy/Manifest b/dev-python/vcrpy/Manifest
index eefd9edc9a54..d11aeb3939a6 100644
--- a/dev-python/vcrpy/Manifest
+++ b/dev-python/vcrpy/Manifest
@@ -1,5 +1,3 @@
-DIST vcrpy-4.0.2.tar.gz 324196 BLAKE2B 8910ba40bd56c7836a92c120c480e633063c78beb1d7c4dcfffb6180135cf0e28586410307ba3e19b3fa484a72a176dbf877f781ade7bae7c81110fde2eedd32 SHA512 17eebc9574ff14f97ad200b99c50b0440a93fbf38afe8ad95f443370d84c43177ac55ab655ffea7e7985b0cd76124eff3c394898e71a0ba0c434014f07e526f9
DIST vcrpy-4.1.0.tar.gz 330122 BLAKE2B a7a2516d4dfcc01da801fb8685ea3b56f50ce474d35477ae36785ea1bfbae113bd3c18fb3faadb13fc81c37fa1d282a84bc60fdd27f4fc4a1f3e952312d7bc5f SHA512 7ad5517cd52f6f31448db9b608d8a7b274741727487ede21b7f80e4060e3ddbb34c731166f67ae7136c86a8d3e7fd23128e035a148f18f771066bfa71319624f
-EBUILD vcrpy-4.0.2.ebuild 1385 BLAKE2B ae7515f0660eb331f2ac40f7644a5438bb1c2170c3444b4866935b70514b81f8481c58e010988196dfe7c718be84f1759865c88a7c19aeba5343594b10a44644 SHA512 7458a9a48a4d11f01eb4058450070716e5d96c11b6260fb426ced67cfdf944a699a9a1ee79bba467fc6628860737ab2a77e616416a40d5ec2f603d3e548dd6a5
EBUILD vcrpy-4.1.0.ebuild 1385 BLAKE2B ae7515f0660eb331f2ac40f7644a5438bb1c2170c3444b4866935b70514b81f8481c58e010988196dfe7c718be84f1759865c88a7c19aeba5343594b10a44644 SHA512 7458a9a48a4d11f01eb4058450070716e5d96c11b6260fb426ced67cfdf944a699a9a1ee79bba467fc6628860737ab2a77e616416a40d5ec2f603d3e548dd6a5
MISC metadata.xml 387 BLAKE2B 09c086ca73a9932b1ac06f46f7c7ef216db357fe831fd6d8f996acedcf24a636420752130597318f4cc0a8d11a584d2162a892ca412403d1bbf15cdd86a1fbaa SHA512 09ba6aaf53089115dc98031b4dba4d526864b6d38ba7950fc3fccd9c2b1a0e14702f5235b3923a41300fabd4152e06eae22e20e86b54795bee453a184bd8828e
diff --git a/dev-python/vcrpy/vcrpy-4.0.2.ebuild b/dev-python/vcrpy/vcrpy-4.0.2.ebuild
deleted file mode 100644
index 3eb99b56e0ee..000000000000
--- a/dev-python/vcrpy/vcrpy-4.0.2.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Automatically mock your HTTP interactions to simplify and speed up testing"
-HOMEPAGE="https://github.com/kevin1024/vcrpy"
-#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-SRC_URI="https://github.com/kevin1024/vcrpy/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- >=dev-python/six-1.5[${PYTHON_USEDEP}]
- dev-python/urllib3[${PYTHON_USEDEP}]
- dev-python/wrapt[${PYTHON_USEDEP}]
- dev-python/yarl[${PYTHON_USEDEP}]
- "
-BDEPEND="
- test? (
- dev-python/pytest-httpbin[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # tests requiring Internet
- rm tests/integration/test_aiohttp.py || die
- sed -e 's:test_flickr_should_respond_with_200:_&:' \
- -e 's:test_amazon_doctype:_&:' \
- -i tests/integration/test_wild.py || die
- sed -e 's:testing_connect:_&:' \
- -i tests/unit/test_stubs.py || die
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- local -x REQUESTS_CA_BUNDLE=$("${EPYTHON}" -m pytest_httpbin.certs)
- pytest -vv || die "Tests fail with ${EPYTHON}"
-}