summaryrefslogtreecommitdiff
path: root/dev-python/vcrpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-23 14:59:31 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-23 14:59:31 +0100
commit764cacf515464f89b60c94a29b3b7262479feb22 (patch)
treec29184ca60bf08fd667d410fac9802dd3df8d099 /dev-python/vcrpy
parent955b5fcaf4acc77c39a1f145d7c56e99f13083a7 (diff)
gentoo auto-resync : 23:05:2023 - 14:59:31
Diffstat (limited to 'dev-python/vcrpy')
-rw-r--r--dev-python/vcrpy/Manifest1
-rw-r--r--dev-python/vcrpy/vcrpy-4.2.1-r1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/vcrpy/Manifest b/dev-python/vcrpy/Manifest
index b323633725d2..f7268afdd6c2 100644
--- a/dev-python/vcrpy/Manifest
+++ b/dev-python/vcrpy/Manifest
@@ -1,3 +1,4 @@
DIST vcrpy-4.2.1.gh.tar.gz 331180 BLAKE2B 345e4c148963e2109d02be4e96986083236bd29fa8049c7cc54483f12d0506cde5c116b6f2fe80e099599b22a73e2f6240f7bb91e4a7d8af7f4e8e741097160d SHA512 59231e5164cda3099b18d099f0ef97e062e6401e52e5dfc4022aa89ca02881e9e6e3c782f12c288f5281b3b3bf175dc33a267bc6d2b40791582a1221f5d7aaab
+EBUILD vcrpy-4.2.1-r1.ebuild 1667 BLAKE2B 9d68df0c82ddbfdf803a38bc83e65407a606259e9f9f5ae3a2b70da57c0bfd42144358e4e9ccfa5677e7b1bc6b36f024e31574d5751f5c0c0b36a60c22a949c0 SHA512 da8149b41c165462c6a4059a8687b87aba162d0ff12df138fb9c686b64ddc18ce320f7531701e41b4c1d2ec1d7d4de841c0113eff218f345a539117d5162be8c
EBUILD vcrpy-4.2.1.ebuild 1592 BLAKE2B 916cf1b8db402859ea682ae08d02eec1310a222a4ed349082f7ce73cddc330c50db73e18beda03e0ff0c54e9242180c192df6bd8e6e1fe4164b381c19ac6bd09 SHA512 704a4edbacef601d7015c12fb1a70a5d64be413d3404e7f79d459ae404a4663bea3b48117b91751a42e046d7595b1cef985c841814a67df3426a7bbd7207368f
MISC metadata.xml 388 BLAKE2B fd31293bd6085e6a93816a1813a8c3a9d046ed3d932fba5b32b454a71e7535606ba92815699b7ca10fc837b07a5335df54d5fae8c860a7ea88c6ea72891d0620 SHA512 0360ac6f113035ffd1991d2a42000f290c9d0a3fa8c4dac9abfde0eecafd23e1ff9929d8ee521f83a924c523992fabc5cb4353079bf7c52dac9f906a31d4da55
diff --git a/dev-python/vcrpy/vcrpy-4.2.1-r1.ebuild b/dev-python/vcrpy/vcrpy-4.2.1-r1.ebuild
new file mode 100644
index 000000000000..d7df7e9d76bc
--- /dev/null
+++ b/dev-python/vcrpy/vcrpy-4.2.1-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically mock your HTTP interactions to simplify and speed up testing"
+HOMEPAGE="
+ https://github.com/kevin1024/vcrpy/
+ https://pypi.org/project/vcrpy/
+"
+SRC_URI="
+ https://github.com/kevin1024/vcrpy/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+# <urllib3-2 for https://github.com/kevin1024/vcrpy/issues/688.
+RDEPEND="
+ >=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/six-1.5[${PYTHON_USEDEP}]
+ <dev-python/urllib3-2[${PYTHON_USEDEP}]
+ dev-python/wrapt[${PYTHON_USEDEP}]
+ dev-python/yarl[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # these tests require Internet
+ tests/integration/test_aiohttp.py
+ tests/integration/test_boto.py
+ tests/integration/test_httplib2.py::test_effective_url
+ tests/integration/test_httpx.py
+ tests/integration/test_urllib2.py::test_effective_url
+ tests/integration/test_urllib3.py::test_redirects
+ tests/integration/test_wild.py::test_amazon_doctype
+ tests/integration/test_wild.py::test_flickr_should_respond_with_200
+ tests/unit/test_stubs.py::TestVCRConnection::testing_connect
+ )
+
+ local -x REQUESTS_CA_BUNDLE=$("${EPYTHON}" -m pytest_httpbin.certs)
+ epytest
+}