summaryrefslogtreecommitdiff
path: root/dev-python/vcrpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-31 10:44:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-31 10:44:36 +0100
commit53aea9d709c9286028405b25584181507f47442f (patch)
treee7b1ada98149b1cc40791b5bb7616d133d80d46c /dev-python/vcrpy
parent358368569cfce7dc6be9a6faed29805babe0e371 (diff)
gentoo auto-resync : 31:07:2023 - 10:44:36
Diffstat (limited to 'dev-python/vcrpy')
-rw-r--r--dev-python/vcrpy/Manifest2
-rw-r--r--dev-python/vcrpy/vcrpy-5.1.0.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/vcrpy/Manifest b/dev-python/vcrpy/Manifest
index 2480d541f593..94a8cb76dcd5 100644
--- a/dev-python/vcrpy/Manifest
+++ b/dev-python/vcrpy/Manifest
@@ -1,3 +1,5 @@
DIST vcrpy-5.0.0.gh.tar.gz 336090 BLAKE2B f8460956456c332be24736153326651a319f3c25f8a38aab27f5a39ff9e312d0643ce702951cd906e735cbaa7c469cc948ce7599a37c767ef379fa10ff5ff69e SHA512 dcf1564b9e8640fe4998d13f4a74a892c6ac152bade6db2b040577e7a3b5e83b87f02a3ea93d58d3102ec6bbd6e452f5bd85c03273fb67fd6800caf87b5f3c6b
+DIST vcrpy-5.1.0.gh.tar.gz 337183 BLAKE2B 76805db7c034fe4f6e0d6fb18340ad24a25a28ece4576d97958d689e46667a8ab2fb6cdc8186f635a7c4f4833d4ea541573bf6c5e0f775f842e60683336ad87e SHA512 dfb2e02027ed2e37f4c2201b410847cf1f03b1999853e3f838e49abf1e93641d58addb18f6144c484f9d4618693b9a99d73dc7fb55eb1de2c383109e054e3713
EBUILD vcrpy-5.0.0.ebuild 1443 BLAKE2B b3126e7a64c2e90cefd39e7260c8bb22c41b5b64f0c4e1734e1e8272b2cd026f8359f93a30b4ebecdfd9eb404681f9ab1464cddcc27581e7b561f44bdc13b5ad SHA512 0d4fde7b54fcb658a5a82e79f305217a8b01fbca359d8362dc5e58e0eea7b2daec2f812cea64e0e82f66bae0c4526032b251095a7f43213a6d16a6b4c5122f6b
+EBUILD vcrpy-5.1.0.ebuild 1685 BLAKE2B dab7647942c7a0ec9c178e9a41ecd27ca03fd86f8d396395862a44898eb06354e8db2674e3518529d55a762729eb604a3d8000ff65d4991ad07e06a26b292c6c SHA512 46bac337e1df200392c44d37c1afa3349b5fbfa21bad5737791a06d30ba12cd633b18f2bc8eb310192107d53c627815fd14bd41a0d14b5e41ee714fff2bd80ce
MISC metadata.xml 388 BLAKE2B fd31293bd6085e6a93816a1813a8c3a9d046ed3d932fba5b32b454a71e7535606ba92815699b7ca10fc837b07a5335df54d5fae8c860a7ea88c6ea72891d0620 SHA512 0360ac6f113035ffd1991d2a42000f290c9d0a3fa8c4dac9abfde0eecafd23e1ff9929d8ee521f83a924c523992fabc5cb4353079bf7c52dac9f906a31d4da55
diff --git a/dev-python/vcrpy/vcrpy-5.1.0.ebuild b/dev-python/vcrpy/vcrpy-5.1.0.ebuild
new file mode 100644
index 000000000000..e3d29e7c02be
--- /dev/null
+++ b/dev-python/vcrpy/vcrpy-5.1.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically mock your HTTP interactions to simplify and speed up testing"
+HOMEPAGE="
+ https://github.com/kevin1024/vcrpy/
+ https://pypi.org/project/vcrpy/
+"
+SRC_URI="
+ https://github.com/kevin1024/vcrpy/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.16.2[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/wrapt[${PYTHON_USEDEP}]
+ dev-python/yarl[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # these tests are failing with recent dev-python/werkzeug; losely related:
+ # https://github.com/kevin1024/vcrpy/issues/645
+ tests/integration/test_record_mode.py::test_new_episodes_record_mode_two_times
+ tests/integration/test_urllib2.py::test_random_body
+ tests/integration/test_urllib2.py::test_multiple_requests
+ # broken in general
+ tests/integration/test_boto.py
+ # Internet
+ tests/integration/test_tornado.py
+ # broken by simplejson, doesn't seem important
+ # https://github.com/kevin1024/vcrpy/issues/751
+ tests/unit/test_serialize.py::test_serialize_binary_request
+ )
+
+ local -x REQUESTS_CA_BUNDLE=$("${EPYTHON}" -m pytest_httpbin.certs)
+ epytest -m 'not online'
+}