summaryrefslogtreecommitdiff
path: root/dev-python/vcrpy/vcrpy-5.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-22 14:44:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-22 14:44:10 +0100
commit63627de4936707c40b5c4dca4f23e9fe1e9c4837 (patch)
tree0882ba9f0e330ae7e1f2f3306a6683000060355d /dev-python/vcrpy/vcrpy-5.1.0.ebuild
parent940cec7afea0fff03b206c62a512335e6f9d2d00 (diff)
gentoo auto-resync : 22:10:2023 - 14:44:09
Diffstat (limited to 'dev-python/vcrpy/vcrpy-5.1.0.ebuild')
-rw-r--r--dev-python/vcrpy/vcrpy-5.1.0.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/dev-python/vcrpy/vcrpy-5.1.0.ebuild b/dev-python/vcrpy/vcrpy-5.1.0.ebuild
index daa52ed9d3d6..0cc7495e8266 100644
--- a/dev-python/vcrpy/vcrpy-5.1.0.ebuild
+++ b/dev-python/vcrpy/vcrpy-5.1.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
@@ -36,6 +36,10 @@ BDEPEND="
)
"
+PATCHES=(
+ "${FILESDIR}/${P}-py312.patch"
+)
+
distutils_enable_tests pytest
python_test() {
@@ -52,6 +56,10 @@ python_test() {
# broken by simplejson, doesn't seem important
# https://github.com/kevin1024/vcrpy/issues/751
tests/unit/test_serialize.py::test_serialize_binary_request
+ # new httpbin, sigh
+ # https://github.com/kevin1024/vcrpy/issues/761
+ tests/integration/test_basic.py::test_basic_json_use
+ tests/integration/test_register_persister.py::test_load_cassette_with_custom_persister
)
local -x REQUESTS_CA_BUNDLE=$("${EPYTHON}" -m pytest_httpbin.certs)