summaryrefslogtreecommitdiff
path: root/dev-python/uvloop
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-14 17:40:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-14 17:40:19 +0100
commitb23b1d43c4a10df85088f74d98a914917f114538 (patch)
tree6dc0ff9e7ed8d4efbb297e572d216fb9c85efbb7 /dev-python/uvloop
parent57aee2868b3c58313cc276d2871eacfb8c95c020 (diff)
gentoo auto-resync : 14:10:2023 - 17:40:19
Diffstat (limited to 'dev-python/uvloop')
-rw-r--r--dev-python/uvloop/Manifest4
-rw-r--r--dev-python/uvloop/uvloop-0.17.0.ebuild3
-rw-r--r--dev-python/uvloop/uvloop-0.18.0.ebuild86
3 files changed, 92 insertions, 1 deletions
diff --git a/dev-python/uvloop/Manifest b/dev-python/uvloop/Manifest
index a0a93b72d360..a4d023a620db 100644
--- a/dev-python/uvloop/Manifest
+++ b/dev-python/uvloop/Manifest
@@ -1,3 +1,5 @@
DIST uvloop-0.17.0.tar.gz 2279973 BLAKE2B 7ccbf3b8e723e36c1010a70e256de0ad1a9728fe10b3538e05c57157b16ea7e5369347c855cd1460e49f89197ebb05628c4b6fcd7e50c623b1aaa5890ac64b5f SHA512 861d7f28ad879ecbfa40d53b9626e38660f02618fd433edbd5a8ea5100a17ade042a26549def04bc23f928aca3adc83d62503f0548038cd400284f5654003ee4
-EBUILD uvloop-0.17.0.ebuild 1852 BLAKE2B 7c77694758b414e1731c4f62d8313324cfe60ea1bd4abd657e41da420757e369657ebf688164e77a9ba5fe7bb34798fe249aba5fcb68200dd9e820fb68363c61 SHA512 959a1c45321d1e3d05ffaacda6ca2eeb3c507d0d544b293f5d5c3ccd8101157dffda545d6adb046adb7a727101fb09b70a7d4f57510f1b6bb149f529805ee0f8
+DIST uvloop-0.18.0.tar.gz 2319264 BLAKE2B 9aeef9278ec97dce62458b3ce4833ef5beeb101d3feaf5b2e45d1ac05b2f40c21bcd6aa3135694c8b9dc9e8078cbd0c74d113784a10f94039f6bbeaf24b06f1f SHA512 1ce01f3e4fca15d1f76c71eb29abb608f6f65d6ebdb3f79ed7c63db5b96bb1325f7a7d97c3adbf8cdb2506907ad13a1c88c767fd3a143cd728f9153ec8958d0e
+EBUILD uvloop-0.17.0.ebuild 2006 BLAKE2B a932053b2c33785843328489ae4af8efc57ab51dc5575aed65d56b8a94a34604f460e8bd63e2259031a1254d47ca3c5ec4d67a68a1eaedf241002e8a0e358068 SHA512 4457fde951946eb5940539f632af9c67418324bdf3a3fec150a22e7d88e6eb9ebe7c0bd8a6b43f2d56a714f61eaaadeb4bbaeba72286e0809cff765a442c48d5
+EBUILD uvloop-0.18.0.ebuild 2013 BLAKE2B 5f7a7056c89e1769a6a1bda8aee13aa79b2b21421d8f4650125901b4a408dfd2b1a3d9ebeb7ee83d394064528970b2ab96f3d5d28609358dee059e46f76f2f51 SHA512 2c3f537c29ca5e173d49949ddc3953b9e9e98ddc6e76c4fa58b82ad95437ab09d093261f2d338f20a247377704be40ba37b4f91b7a22d4e7ce655f8f954b3fd2
MISC metadata.xml 527 BLAKE2B 2db44bdfb681fcce35ef35f13155293ac3fdffa12a695b654ed8acc608cf1f769243136e66b6b2c1afd57caa7e59a66a60d34631c37a4b98a474bd0635fcbaa3 SHA512 02540835a23405c467293395fa7984741e02ca1aca75f527edd3b988d307b41db0f729d5cc0b3a826a652fb7104dec7be86a9a57f4d5646d2af87255cc2d90de
diff --git a/dev-python/uvloop/uvloop-0.17.0.ebuild b/dev-python/uvloop/uvloop-0.17.0.ebuild
index 3ed6b400cc21..5b6839d09ea7 100644
--- a/dev-python/uvloop/uvloop-0.17.0.ebuild
+++ b/dev-python/uvloop/uvloop-0.17.0.ebuild
@@ -71,6 +71,9 @@ python_test() {
tests/test_process.py::Test_AIO_Process::test_process_env_2
# hangs
tests/test_tcp.py::Test_AIO_TCPSSL::test_remote_shutdown_receives_trailing_data
+ # crashes on assertion
+ # https://github.com/MagicStack/uvloop/issues/574
+ tests/test_cython.py::TestCythonIntegration::test_cython_coro_is_coroutine
)
rm -rf uvloop || die
diff --git a/dev-python/uvloop/uvloop-0.18.0.ebuild b/dev-python/uvloop/uvloop-0.18.0.ebuild
new file mode 100644
index 000000000000..9c5ab1780086
--- /dev/null
+++ b/dev-python/uvloop/uvloop-0.18.0.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Ultra-fast implementation of asyncio event loop on top of libuv"
+HOMEPAGE="
+ https://github.com/magicstack/uvloop/
+ https://pypi.org/project/uvloop/
+"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 -riscv ~sparc ~x86"
+LICENSE="MIT"
+SLOT="0"
+IUSE="examples"
+
+DEPEND="
+ >=dev-libs/libuv-1.11.0:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ <dev-python/cython-3[${PYTHON_USEDEP}]
+ >=dev-python/cython-0.29.32[${PYTHON_USEDEP}]
+ test? (
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-22.0.0[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ rm -r vendor || die
+ cat <<-EOF >> setup.cfg || die
+ [build_ext]
+ use_system_libuv=True
+ cython_always=True
+ EOF
+
+ # flake8 only
+ #rm tests/test_sourcecode.py || die
+ # force cythonization
+ rm uvloop/loop.c || die
+ # hangs
+ #sed -i -e 's:test_remote_shutdown_receives_trailing_data:_&:' \
+ # tests/test_tcp.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local EPYTEST_IGNORE=(
+ # linting
+ tests/test_sourcecode.py
+ )
+ local EPYTEST_DESELECT=(
+ # TODO: expects some... cython_helper?
+ tests/test_libuv_api.py::Test_UV_libuv::test_libuv_get_loop_t_ptr
+ # unhappy about sandbox injecting its envvars
+ tests/test_process.py::Test_UV_Process::test_process_env_2
+ tests/test_process.py::Test_AIO_Process::test_process_env_2
+ # hangs
+ tests/test_tcp.py::Test_AIO_TCPSSL::test_remote_shutdown_receives_trailing_data
+ # crashes on assertion
+ # https://github.com/MagicStack/uvloop/issues/574
+ tests/test_cython.py::TestCythonIntegration::test_cython_coro_is_coroutine
+ )
+
+ rm -rf uvloop || die
+ epytest -s
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}