summaryrefslogtreecommitdiff
path: root/dev-python/utidylib/utidylib-0.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-07 21:14:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-07 21:14:14 +0000
commit6d44cd74809cea5f81bf52ff9cd0aa902d6b6866 (patch)
tree4045142b80c7e0479c627a84e3f0de03e574df19 /dev-python/utidylib/utidylib-0.9.ebuild
parent8615c518b1f1d03130f21656a1a026959bb1e9c9 (diff)
gentoo auto-resync : 07:12:2022 - 21:14:14
Diffstat (limited to 'dev-python/utidylib/utidylib-0.9.ebuild')
-rw-r--r--dev-python/utidylib/utidylib-0.9.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/utidylib/utidylib-0.9.ebuild b/dev-python/utidylib/utidylib-0.9.ebuild
new file mode 100644
index 000000000000..095b63b34c3a
--- /dev/null
+++ b/dev-python/utidylib/utidylib-0.9.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="TidyLib Python wrapper"
+HOMEPAGE="
+ https://cihar.com/software/utidylib/
+ https://github.com/nijel/utidylib/
+ https://pypi.org/project/uTidylib/
+"
+SRC_URI="
+ https://github.com/nijel/utidylib/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=app-text/htmltidy-5.0.0
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
+
+EPYTEST_DESELECT=(
+ # https://github.com/nijel/utidylib/issues/9
+ tidy/test_tidy.py::TidyTestCase::test_missing_load
+)