summaryrefslogtreecommitdiff
path: root/dev-python/userpath
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-07 22:29:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-07 22:29:07 +0100
commitde1079fbccb3bceb32818385f756637e266f2107 (patch)
tree570d809a9fcbf27d05be1a94090b087521c5514b /dev-python/userpath
parent2cd907d16458ba3a99ec82155d7268e2d991a078 (diff)
gentoo auto-resync : 07:09:2023 - 22:29:07
Diffstat (limited to 'dev-python/userpath')
-rw-r--r--dev-python/userpath/Manifest2
-rw-r--r--dev-python/userpath/userpath-1.9.1.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/userpath/Manifest b/dev-python/userpath/Manifest
index 25231e2d0c18..22e876edabe0 100644
--- a/dev-python/userpath/Manifest
+++ b/dev-python/userpath/Manifest
@@ -1,3 +1,5 @@
DIST userpath-1.9.0.gh.tar.gz 11090 BLAKE2B 70eac3d629c71604047d9dfa4eaf2eeb90011d0b943367aacc0e4e1efb7d45de0efb8075404510e791bd8da3609423d29503101943edc108aa012e8018e53b63 SHA512 a5683a7423465426debda02d58b2f5ef8d17d38d2fac2378cdf3075a2a6f0b7d75210bb1eac30966d323ec5f25073cc9286ae1b37acaa1bf7785da02a4c40805
+DIST userpath-1.9.1.gh.tar.gz 11183 BLAKE2B 91d5eec83ec1720cf7f65f9d67bb09d86b6679fc540026ba0b7b99522bb4e062c35bb2d6d751684f3cbaa78bca5ab1e1cb34b25a937f744115a9b80096637858 SHA512 a98b000a0968f81131eb5a91822fda72bc38e6aa2b2a85be43974c37155cbf23aa2698dac1969f078bcca1ebcbc9bd5ef71e4437eae691b7358610bcc74859d5
EBUILD userpath-1.9.0.ebuild 569 BLAKE2B 08a9b36652591841c5c48102c66fdd13f1e4cf2177bb2db0537536d6f1dbe2b8a997800ca2110ab2a1ed70c739e4f3af2a4a07ad8140a63290612b2881721608 SHA512 795a316db4eb0c151cab5d707a5be0a32944bc384ddb467f628b238706f8c106899aa8bf81da4144bb06b1f7a9e82d09cb543930beab2aaa0bcee2bab422df9b
+EBUILD userpath-1.9.1.ebuild 569 BLAKE2B 08a9b36652591841c5c48102c66fdd13f1e4cf2177bb2db0537536d6f1dbe2b8a997800ca2110ab2a1ed70c739e4f3af2a4a07ad8140a63290612b2881721608 SHA512 795a316db4eb0c151cab5d707a5be0a32944bc384ddb467f628b238706f8c106899aa8bf81da4144bb06b1f7a9e82d09cb543930beab2aaa0bcee2bab422df9b
MISC metadata.xml 389 BLAKE2B d1956c245f6188560ce4e95dee67c0f3e7d41dc44c54cc0fb2eefa88156d4121384d7206ff4b7dd10be127ddd9c27d9e2b9baa04db225263457e1fa020bc6a6e SHA512 899f4930827a110dc03f5a9905e765342f7f619a39d4095297bfad4175b34326df6d1e33d08a2db9b051f72f94b24ac87b444fafa09bd15e386e472d1be1802a
diff --git a/dev-python/userpath/userpath-1.9.1.ebuild b/dev-python/userpath/userpath-1.9.1.ebuild
new file mode 100644
index 000000000000..e9cbe4cde968
--- /dev/null
+++ b/dev-python/userpath/userpath-1.9.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Cross-platform tool for adding locations to the user PATH"
+HOMEPAGE="
+ https://github.com/ofek/userpath/
+ https://pypi.org/project/userpath/
+"
+SRC_URI="
+ https://github.com/ofek/userpath/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest