summaryrefslogtreecommitdiff
path: root/dev-python/urwidtrees/urwidtrees-1.0.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-27 20:49:18 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-27 20:49:18 +0000
commitc5ee568457ac776b65b71fa444e0dd47535bc44a (patch)
tree1aa40f593e598d7c8352c1d99a30ff9315e690af /dev-python/urwidtrees/urwidtrees-1.0.3-r1.ebuild
parent8eccda982236f2cfe9188bdcaffd9168134f39a9 (diff)
gentoo auto-resync : 27:01:2023 - 20:49:18
Diffstat (limited to 'dev-python/urwidtrees/urwidtrees-1.0.3-r1.ebuild')
-rw-r--r--dev-python/urwidtrees/urwidtrees-1.0.3-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/urwidtrees/urwidtrees-1.0.3-r1.ebuild b/dev-python/urwidtrees/urwidtrees-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..8faf91778bb7
--- /dev/null
+++ b/dev-python/urwidtrees/urwidtrees-1.0.3-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tree widgets for urwid"
+HOMEPAGE="https://github.com/pazz/urwidtrees"
+SRC_URI="
+ https://github.com/pazz/urwidtrees/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-python/urwid-1.1.0[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-no-mock-dep.patch #770391
+)
+
+distutils_enable_sphinx docs/source
+
+src_prepare() {
+ find -name '*.py' -exec \
+ sed -i -e '1i# -*- coding: utf-8 -*-' {} + || die
+
+ distutils-r1_src_prepare
+
+ local md
+ for md in *.md; do
+ mv "${md}" "${md%.md}" || die
+ done
+}