summaryrefslogtreecommitdiff
path: root/dev-python/urllib3
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:18:26 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:18:26 +0100
commit6c30cc2d5bd48ddbdbe8d75544899cd5dbfcaba4 (patch)
tree6ef7f6e1d48141a5da904d788b906da5bba4b697 /dev-python/urllib3
parent62f82c107c3904ac6917ece47301d2999c7dd90e (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/urllib3')
-rw-r--r--dev-python/urllib3/Manifest3
-rw-r--r--dev-python/urllib3/files/urllib3-1.23-tornado5.patch72
-rw-r--r--dev-python/urllib3/urllib3-1.23.ebuild6
3 files changed, 79 insertions, 2 deletions
diff --git a/dev-python/urllib3/Manifest b/dev-python/urllib3/Manifest
index c75f58d4cde5..53f176871e6c 100644
--- a/dev-python/urllib3/Manifest
+++ b/dev-python/urllib3/Manifest
@@ -1,5 +1,6 @@
+AUX urllib3-1.23-tornado5.patch 2878 BLAKE2B 7d64d012de5f0d83043ca5c6262d4e395faa888b582cc2c094c82c90aad3bb7e3e7bf835c002bcc72339974d06b5b211d22571a0470b44e453024626e47ee507 SHA512 c4c1facce9e90a8c8b845e4ca9b5c1b4bd1400fa9b2841172bd8a721ed96fac36cdead6014bf33ec841237f7cd4cb0994283f1a62840e22f829f9f0234d1cfde
DIST urllib3-1.22.tar.gz 226083 BLAKE2B 6d3067ea1c9c90e2e759e6319115ed3d29ca1e31c4d1721d7e7aeed432ea4df22635d92fdb9ea91a411bbe67c72160abaa19e0d42870be0b0a866c003db6ec62 SHA512 132b69d7f390916bdcde66d46fbf0189d0c1f976f91778dcb0a9ef8174487b7bb4b37b9139e84f7c70234803be95284448aba0b820f3b54530c0c497ca7a1dc9
DIST urllib3-1.23.tar.gz 228314 BLAKE2B 63cd0ed046ade8b775067df92f3589bdfa21788481292724ec6af85b5789cc990cd267e1a0dfd925529d147441232a89b4f1b23a1276fc7a68a7047cbf2ae8a4 SHA512 6baa76ad3bebc639d7ec0a042d809fba7ef3110de6164a321756389c250e218728d178708611049d91f39d17f24b8b08585edb2f2c260c987bd4c7204e0c0b5f
EBUILD urllib3-1.22.ebuild 1755 BLAKE2B f74bfb8db93173a4388ae644e81cf4e3c8a3fc491ed0f3453def06a323b03ffe52bc471a32c0fdab64880554417082f0c4b7967f9d1bb185e04afdc65da3faf4 SHA512 8bab85bac5e97dadc1729434a108c82609a82a69b8af505aa77f267c897a368e49d23ba176ce45f583517e6844185ca2524c09cd31a1a76795dc99b8e6d1849f
-EBUILD urllib3-1.23.ebuild 1838 BLAKE2B 5f60d3a2d3226c9fef09eb69488c3d72855408dadb7d4285ed5f07d413ef3411b33bfff56ad5e51ef88945a6f7b3a83734af1b4291d338489635c99bd5ba4cc4 SHA512 d17da2ac8cf45a85340db499938f9c745491cc9131d32a9b4e1252d312c6e61bc48f4e6c21b2a05018d5b3e6bbbe5c1853c372437e0848bb88fe383fa1060a22
+EBUILD urllib3-1.23.ebuild 1864 BLAKE2B 550d527d91cfbf99ed366064a4ae0f7c6618daf968fe604a91f0518dc6207b726c0aa4f41a6dfdf637f450af391bd1bea3f526c443c92c3eb7bf68532b2a91a9 SHA512 d008993c701cf28d2126dc5f3aa5671945235cf4b65b430353d99e27103a79b668f13db5be94a80602751e55eb59ed3eaaabd1af91ebcc78e17a2622d3e71e77
MISC metadata.xml 376 BLAKE2B 2e9ba1b23bd9ab2770d23ce9bdf21f4083f46184c22d1dc0bd449b6605c24a2ef0168e1503327b549ba55e81b7bb52fe5f73fa375f06f3c64fabfac6cf5a9d77 SHA512 97d216a4841d8c78655c923060a0040b75fbb2d19a42e51081fc63a4af80514db5abf09a02706cc52387ab7ac72e964f947f1ded50bcc7f8fae6d022d5353543
diff --git a/dev-python/urllib3/files/urllib3-1.23-tornado5.patch b/dev-python/urllib3/files/urllib3-1.23-tornado5.patch
new file mode 100644
index 000000000000..b5224564c56a
--- /dev/null
+++ b/dev-python/urllib3/files/urllib3-1.23-tornado5.patch
@@ -0,0 +1,72 @@
+From f8c3e96df731eccda202e0dc909f0a51cdc41267 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Sat, 14 Jul 2018 12:21:50 +0200
+Subject: [PATCH] dummyserver: Update for tornado-5 API changes
+
+Tornado 5 has apparently removed support for multiple IOLoops,
+and appropriately removed the io_loop parameter to the server class
+in favor of using IOLoop.current(). Update the tests to use the latter.
+The code remains compatible with tornado-4.
+---
+ dummyserver/server.py | 9 +++++----
+ dummyserver/testcase.py | 4 ++--
+ 2 files changed, 7 insertions(+), 6 deletions(-)
+
+diff --git a/dummyserver/server.py b/dummyserver/server.py
+index e1745b7..3ba5124 100755
+--- a/dummyserver/server.py
++++ b/dummyserver/server.py
+@@ -226,15 +226,16 @@ def bind_sockets(port, address=None, family=socket.AF_UNSPEC, backlog=128,
+
+
+ def run_tornado_app(app, io_loop, certs, scheme, host):
++ assert io_loop == tornado.ioloop.IOLoop.current()
++
+ # We can't use fromtimestamp(0) because of CPython issue 29097, so we'll
+ # just construct the datetime object directly.
+ app.last_req = datetime(1970, 1, 1)
+
+ if scheme == 'https':
+- http_server = tornado.httpserver.HTTPServer(app, ssl_options=certs,
+- io_loop=io_loop)
++ http_server = tornado.httpserver.HTTPServer(app, ssl_options=certs)
+ else:
+- http_server = tornado.httpserver.HTTPServer(app, io_loop=io_loop)
++ http_server = tornado.httpserver.HTTPServer(app)
+
+ sockets = bind_sockets(None, address=host)
+ port = sockets[0].getsockname()[1]
+@@ -268,7 +269,7 @@ if __name__ == '__main__':
+ from .testcase import TestingApp
+ host = '127.0.0.1'
+
+- io_loop = tornado.ioloop.IOLoop()
++ io_loop = tornado.ioloop.IOLoop.current()
+ app = tornado.web.Application([(r".*", TestingApp)])
+ server, port = run_tornado_app(app, io_loop, None,
+ 'http', host)
+diff --git a/dummyserver/testcase.py b/dummyserver/testcase.py
+index f73f028..d9ff8cf 100644
+--- a/dummyserver/testcase.py
++++ b/dummyserver/testcase.py
+@@ -124,7 +124,7 @@ class HTTPDummyServerTestCase(unittest.TestCase):
+
+ @classmethod
+ def _start_server(cls):
+- cls.io_loop = ioloop.IOLoop()
++ cls.io_loop = ioloop.IOLoop.current()
+ app = web.Application([(r".*", TestingApp)])
+ cls.server, cls.port = run_tornado_app(app, cls.io_loop, cls.certs,
+ cls.scheme, cls.host)
+@@ -170,7 +170,7 @@ class HTTPDummyProxyTestCase(unittest.TestCase):
+
+ @classmethod
+ def setUpClass(cls):
+- cls.io_loop = ioloop.IOLoop()
++ cls.io_loop = ioloop.IOLoop.current()
+
+ app = web.Application([(r'.*', TestingApp)])
+ cls.http_server, cls.http_port = run_tornado_app(
+--
+2.18.0
+
diff --git a/dev-python/urllib3/urllib3-1.23.ebuild b/dev-python/urllib3/urllib3-1.23.ebuild
index 7ac1e3770ebf..7dad09add027 100644
--- a/dev-python/urllib3/urllib3-1.23.ebuild
+++ b/dev-python/urllib3/urllib3-1.23.ebuild
@@ -33,7 +33,6 @@ DEPEND="
test? (
${RDEPEND}
>=www-servers/tornado-4.2.1[$(python_gen_usedep 'python*')]
- <www-servers/tornado-5.0.0[$(python_gen_usedep 'python*')]
dev-python/pytest[${PYTHON_USEDEP}]
)
doc? (
@@ -45,6 +44,11 @@ DEPEND="
# Testsuite written requiring mock to be installed under all Cpythons
python_prepare_all() {
+ local PATCHES=(
+ # support tornado-5
+ "${FILESDIR}"/urllib3-1.23-tornado5.patch
+ )
+
# skip appengine tests
rm -r test/appengine || die