summaryrefslogtreecommitdiff
path: root/dev-python/urllib3
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /dev-python/urllib3
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'dev-python/urllib3')
-rw-r--r--dev-python/urllib3/Manifest2
-rw-r--r--dev-python/urllib3/urllib3-1.25.9.ebuild13
2 files changed, 3 insertions, 12 deletions
diff --git a/dev-python/urllib3/Manifest b/dev-python/urllib3/Manifest
index bbd0ce3f1da3..16134f42e692 100644
--- a/dev-python/urllib3/Manifest
+++ b/dev-python/urllib3/Manifest
@@ -3,5 +3,5 @@ DIST urllib3-1.25.8.tar.gz 261077 BLAKE2B 9625c8bce484e3a0ae8b49a776377d5420a496
DIST urllib3-1.25.9.tar.gz 254921 BLAKE2B bd78d7a1de71ffe3b1f62352bb49f94fd402870f57e86ae07ea5462706c19b0ae1f8e23a7e8a4a83482b57e007cb95f5ae242d179cec7e9568fcb440b9d95b82 SHA512 505f1d9137e469a48ee0de417f2be36946cf1d9bbcf1233280be399a6c6d8650b5b3c6cfcf884b04e0156974da703f48843381b9aab377738a2e60f7d2d3799b
EBUILD urllib3-1.24.2.ebuild 1786 BLAKE2B 3c413607941e08872efa7f4f598e69d6a858adea7505b183ae2efeb7bf418edf8b06fbd04d0f3aa640a50f9ee18616f8b5186f382fb8fc6f250a667348c7d088 SHA512 4f217cb09fc22adb26371a336d42c274be4ca2aa1e8ea5404b8ac97f573b7d7f6c577b8e12a5f9281e1df39e4967614c8f9d9aa626c3544bef20c86053f1a95e
EBUILD urllib3-1.25.8.ebuild 2536 BLAKE2B 1a5167611d39195efd2367a47f709e4e0350f879a27f90ef4ede33fc5c167aabd1b3cfca4e24177649e2a1b12cbb1924860d2ee930bc683d581dd3d857d7be3f SHA512 c257bc9443f3f5464c5d33a79cace27e9305bfbc2b1c2e374a46613cd5d926acf24b298bb79b4fe55a30ea816f6b41f8f9fd3b16fbe129b96e48e45e8ec2af4e
-EBUILD urllib3-1.25.9.ebuild 2540 BLAKE2B 943518b732769dbbaf8fff1c65fe9a19fce496be9810dd0f9066e6632533c6c5d36b915df094fd3ccd1a2c8ced204c4929777a4c48c985aca4aa37cba559fda8 SHA512 39de0a13c296d18b3ce8d218b782d5ccd468a5e49d1d307e2d708b02ef536bc90ac59553b0d6fdc45b08051ff898ec8dd951c10c7d3dab4dea9a7721851175ec
+EBUILD urllib3-1.25.9.ebuild 2108 BLAKE2B baf4fc80008da78cbecfdbd23bf43eda778c04df3aa4b833c8da23505a1e01ce2844e719c917715ac5c2ec5f9fdee8120cc25fd4c32e81da745489fd05a431c1 SHA512 56e0175d192771e81513167872a0df697ed6fab1ffad6447e6ec11659656b3d2052e117290c829a2202d7839c439cfa1a0792c2cfb27bea0dd410e859cc2165b
MISC metadata.xml 523 BLAKE2B b5104cb8130aa670af99f36a2853f4ccbe78f367d5e80a3626a5323237af5f7da1ba6fa5d83586afa1072753f63d918197aa97a578f7e2f1faa82f457c7947a9 SHA512 3c384cd1d75e038ba7b7d3aee93f2f9cc05b61710cd6f45f2f250392994caa253b6c783ce5f321dc72a94e1e94e12527a229d652920492637dfca4eb7b13c457
diff --git a/dev-python/urllib3/urllib3-1.25.9.ebuild b/dev-python/urllib3/urllib3-1.25.9.ebuild
index 013ac015a9f9..a3c2ed92451e 100644
--- a/dev-python/urllib3/urllib3-1.25.9.ebuild
+++ b/dev-python/urllib3/urllib3-1.25.9.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
PYTHON_REQ_USE="ssl(+)"
inherit distutils-r1
@@ -31,7 +31,6 @@ RDEPEND="
brotli? ( dev-python/brotlipy[${PYTHON_USEDEP}] )
"
BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
test? (
$(python_gen_cond_dep "
${RDEPEND}
@@ -40,7 +39,7 @@ BDEPEND="
dev-python/pytest[\${PYTHON_USEDEP}]
>=dev-python/trustme-0.5.3[\${PYTHON_USEDEP}]
>=www-servers/tornado-4.2.1[\${PYTHON_USEDEP}]
- " 'python3*')
+ " python3_{6,7,8,9})
)
"
@@ -57,14 +56,6 @@ python_prepare_all() {
-i test/with_dummyserver/test_https.py || die
sed -e 's:test_request_host_header_ignores_fqdn_dot:_&:' \
-i test/with_dummyserver/test_socketlevel.py || die
- # no clue why those fail, might be tornado's fault, might be just
- # very flaky
- sed -e 's:test_client_no_intermediate:_&:' \
- -i test/with_dummyserver/test_https.py || die
- sed -e 's:test_basic_ipv6_proxy:_&:' \
- -i test/with_dummyserver/test_proxy_poolmanager.py || die
- sed -e 's:test_connection_closed_on_read_timeout_preload_false:_&:' \
- -i test/with_dummyserver/test_socketlevel.py || die
distutils-r1_python_prepare_all
}