summaryrefslogtreecommitdiff
path: root/dev-python/urllib3
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-07 22:48:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-07 22:48:01 +0000
commitc3bc61051d7f12b4c682efa7a5460bbc8815649e (patch)
treeb6d19e96ba3c397fb8278eeb9b68170db92630ba /dev-python/urllib3
parent3517852e3b8a68d1e997770fc0650c5053bafc6c (diff)
gentoo resync : 07.01.2022
Diffstat (limited to 'dev-python/urllib3')
-rw-r--r--dev-python/urllib3/Manifest2
-rw-r--r--dev-python/urllib3/urllib3-1.26.8.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/urllib3/Manifest b/dev-python/urllib3/Manifest
index 611824236c2b..06b35e9c491b 100644
--- a/dev-python/urllib3/Manifest
+++ b/dev-python/urllib3/Manifest
@@ -1,3 +1,5 @@
DIST urllib3-1.26.7.tar.gz 291350 BLAKE2B 5a95ea4df2e5a66ac7f3059b5453e122ae0e40531a23cb743e5a9574778a370d0cee3cb63fe6b29483b27c4a6ec498266ec5a0434db882ce0a79fb8d8400e08d SHA512 6f5a5e6dd5ff99950fcc051495e0a698153b57e20b6c83d869b54c7fece9616909bcf2fe99efc40815f8722996ad93e430bf765ce5c629b912690c286014b86f
+DIST urllib3-1.26.8.tar.gz 294280 BLAKE2B 401801b16c0c5152cabdfe3317cc53bc79a5aec103cc53a22189dcefcf0d022a05f6afac0bd99274a2fe48b6e86da8eb544b78e4c3a1534f000a9756ff15ccd9 SHA512 bcb56faa5dbe6019f70b63c076e118ec5f89e2d0c25f0e415d9db079532c98ced7e636cec5bf26210d4b0a08bb7b5b7a33a5c8648ccdaad129eea3a212a53bc5
EBUILD urllib3-1.26.7.ebuild 1816 BLAKE2B 13b91ca18d4fc18d8772f91d9150aa43a8bb176458fded726511c516367e6767e22db572f439ea1a2c78dd6d8c7b0962f7680097243b70f382adfa619a93ec75 SHA512 49dc88eea220b6226b53eb411e8645e7bf38ec0d16f94e553f8895550995ad021ec1e258f911d5f960fc707889ea96efa345131ee0d2d3aa4d81d9ec1aef55f4
+EBUILD urllib3-1.26.8.ebuild 1824 BLAKE2B dbaacaebb7e726916f4799170e30b71852226758c93bbddedd02ab1f6c3708de55889ba613c222437c52515178e19bc04b16cceac25632e087ed51d02636382e SHA512 0bb5ba86435fa4f47bf32a9cb47230f7343283723f785ae9a57add22a4caa9719e823826861445df2b7620537eec8a98a3b4afbac426bf7da0fdf644c1633dd1
MISC metadata.xml 531 BLAKE2B 3ddfea4b8817c827437a79abae8cf4e9cda95addb1c6505ef13018587720bba0cf0788041c0b4cc8b25f319e7cb1c94117ae25b3cbb567f24373e8e89bedaa7b SHA512 7e7191f0338c4c47f01bdceb3d2c6ed94de2241e77fb3be6cbf3ecf8a0682730392a9ee5adf24304d9a322acc06bd84f4f90f1dddcb258cb2e9ba0de9952b693
diff --git a/dev-python/urllib3/urllib3-1.26.8.ebuild b/dev-python/urllib3/urllib3-1.26.8.ebuild
new file mode 100644
index 000000000000..01b718ef8c5b
--- /dev/null
+++ b/dev-python/urllib3/urllib3-1.26.8.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="ssl(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP library with thread-safe connection pooling, file post, and more"
+HOMEPAGE="https://github.com/urllib3/urllib3"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="brotli test"
+RESTRICT="!test? ( test )"
+
+# dev-python/{pyopenssl,cryptography,idna,certifi} are optional runtime
+# dependencies. Do not add them to RDEPEND. They should be unnecessary with
+# modern versions of python (>= 3.2).
+RDEPEND="
+ >=dev-python/PySocks-1.5.8[${PYTHON_USEDEP}]
+ <dev-python/PySocks-2.0[${PYTHON_USEDEP}]
+ brotli? ( dev-python/brotlicffi[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep "
+ ${RDEPEND}
+ dev-python/brotlicffi[\${PYTHON_USEDEP}]
+ dev-python/mock[\${PYTHON_USEDEP}]
+ dev-python/pytest[\${PYTHON_USEDEP}]
+ dev-python/pytest-freezegun[\${PYTHON_USEDEP}]
+ >=dev-python/trustme-0.5.3[\${PYTHON_USEDEP}]
+ >=www-servers/tornado-4.2.1[\${PYTHON_USEDEP}]
+ " python3_{8..10})
+ )
+"
+
+python_test() {
+ local -x CI=1
+ # FIXME: get tornado ported
+ # please keep in sync with BDEPEND!
+ if ! has "${EPYTHON}" python3.{8..10}; then
+ einfo "Skipping tests on ${EPYTHON}"
+ return
+ fi
+
+ local EPYTEST_DESELECT=(
+ # TODO?
+ test/contrib/test_pyopenssl.py::TestHTTPS_TLSv1_3::test_verified
+ test/with_dummyserver/test_socketlevel.py::TestSocketClosing::test_timeout_errors_cause_retries
+ )
+
+ epytest
+}