summaryrefslogtreecommitdiff
path: root/dev-python/urllib3
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-29 10:15:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-29 10:15:54 +0100
commit9aa80713372911cec499b3adb2cd746790920916 (patch)
treeb8e99dc5dd60ac2094a27cc52f74aada8df38f05 /dev-python/urllib3
parentb4d43e8c611df4a8061b6f88d9e9f6b1e3c83903 (diff)
gentoo resync : 29.06.2021
Diffstat (limited to 'dev-python/urllib3')
-rw-r--r--dev-python/urllib3/Manifest2
-rw-r--r--dev-python/urllib3/urllib3-1.26.6.ebuild65
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/urllib3/Manifest b/dev-python/urllib3/Manifest
index 0c0d5afe6ba9..7dcef89bcfa5 100644
--- a/dev-python/urllib3/Manifest
+++ b/dev-python/urllib3/Manifest
@@ -1,6 +1,8 @@
AUX urllib3-1.26.4-test-ssltransport.patch 1267 BLAKE2B e82ae435cfa8a2821f3f61d91a2e4f9011c5f68d37fddd1a40ae4658566db45717379c48d11299eb260c2f8816f416ac69b0379b3c7f925075ee9c1051aab1bd SHA512 bf5d2bb2b48444724ee1cfb87f4a84b3a63cd6ca598ba4d92a44bde71c66a35b815905de51fe027abb2eea63ae353dc0df2338ddd4f819f678f8a39b5c6d685b
DIST urllib3-1.26.4.tar.gz 293008 BLAKE2B 6ca88861baa87814d3856cd0f1fa0a6cb9e11ee745c782b598c4f5fe74b195ba47e8430b993ed8a5fb269153d700e4a803cd2ebc177e20e3186b3b26612262c7 SHA512 daf2ba432f2e4edaa6aa8c6bdaaea21fcb77cc5fdfd991f89b1f753b4f9901faab04120841e9fa8d93e2bd3d72cbdb647f1492d882266b4e0281c725e8d55a7a
DIST urllib3-1.26.5.tar.gz 292865 BLAKE2B 0b22a485635f70f198c022c13d03af2b1a9b6907276e3bc3acaa2242e1c632447762f86e9588e735462e6479ff93a172f458691ea9bf28ceaebd5e1cfbc55501 SHA512 4a1899b223b00894d49f6dff5fc95d410e5b0ab28c11f7e3cd82d03e50438b0c5b0adf693a33fd80f1586312dc0012836713998674da15531bf82d52645881f6
+DIST urllib3-1.26.6.tar.gz 289927 BLAKE2B 197b0df759b27fc4906c565426e9c7b533fad56f10695ab5ae6c6c4d05d5c889dba906be526d8b8f41405f29696046b7db6e2cbb2fa16843af80e072138cc35f SHA512 19eb4b88b7a575db717db420ff79b304769d9a6d2b576a236d69719101c4d52d6b0079bd049c885e630f0dfd60471f8bb33836847e0569652cddece910ec2979
EBUILD urllib3-1.26.4.ebuild 4265 BLAKE2B 17f981911cc9adf17b7fa989833a47554127d9bdc7c1f49605c0c949c0c82ca24e48e5e1bea38f8f549c5eb00e047cfddf03a967a0ea7bf1e83afa9901044f7f SHA512 f9d2190c141b4c4daa2d9e3d4fe577acb3d0787c8591ca46bce3ccf5e22872349fa459e63cd5cb96710f25a5910a2ce600d0003b7e72e5f9c4e0797c459d07f2
EBUILD urllib3-1.26.5.ebuild 1970 BLAKE2B c59e0c4b55feb44a0880f19ab50ddf8ff49bda077d89acc071bea27211ebcec6f8f41c275b2e87a2395311ce380d5e547f554315ceb0807f6780e0fec151256f SHA512 7cae227afbfe5d4b8ca30f5a85e2267af6108a64f04cdc96a3b474b7f039dfc9326aada8636758817a3dfe5f66039db58fcd0de2cb4b456c4410723ccafad187
+EBUILD urllib3-1.26.6.ebuild 1970 BLAKE2B e3dee58d1f4b280c2c2c8a84afcb9356450f045267ec321467933ffac73a9de5050473524d971cd65724b8de1b3e22ea824fc0cfd933a3083bd46b0b6bbb6dc0 SHA512 4d14b178b5d4df05883498a6cb0b38d1630ba11e20b3d93ccb57a27bf99e0d510389f1344155177501472f4ec4f39d8bf5c4ef4fcb6141a3d0d0e2eed5a86219
MISC metadata.xml 530 BLAKE2B 148b6a1936566b905f38f00ec231a832e827bbdd4f6c2ceabe521779b08c1dbf60bdfa182234e8e67b6708efadd09d29e93c151f7c3d1d4fcd5ece3e3d9c0839 SHA512 9ab9fa9ecb34855be0f6e7914f70eadca67854fde865765b1257feec6c841bccd8276ad81f8d9bbfb544ca753c3d27681d6cc841cee008efca5ba72f5a236f3e
diff --git a/dev-python/urllib3/urllib3-1.26.6.ebuild b/dev-python/urllib3/urllib3-1.26.6.ebuild
new file mode 100644
index 000000000000..b68c311d9396
--- /dev/null
+++ b/dev-python/urllib3/urllib3-1.26.6.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="ssl(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP library with thread-safe connection pooling, file post, and more"
+HOMEPAGE="https://github.com/urllib3/urllib3"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="brotli test"
+RESTRICT="!test? ( test )"
+
+# dev-python/{pyopenssl,cryptography,idna,certifi} are optional runtime
+# dependencies. Do not add them to RDEPEND. They should be unnecessary with
+# modern versions of python (>= 3.2).
+RDEPEND="
+ >=dev-python/PySocks-1.5.8[${PYTHON_USEDEP}]
+ <dev-python/PySocks-2.0[${PYTHON_USEDEP}]
+ brotli? ( dev-python/brotlicffi[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep "
+ ${RDEPEND}
+ dev-python/brotlicffi[\${PYTHON_USEDEP}]
+ dev-python/mock[\${PYTHON_USEDEP}]
+ dev-python/pytest[\${PYTHON_USEDEP}]
+ dev-python/pytest-freezegun[\${PYTHON_USEDEP}]
+ >=dev-python/trustme-0.5.3[\${PYTHON_USEDEP}]
+ >=www-servers/tornado-4.2.1[\${PYTHON_USEDEP}]
+ " python3_{6..10})
+ )
+"
+
+python_prepare_all() {
+ # tests failing if 'localhost.' cannot be resolved
+ sed -e 's:test_dotted_fqdn:_&:' \
+ -i test/with_dummyserver/test_https.py || die
+ sed -e 's:test_request_host_header_ignores_fqdn_dot:_&:' \
+ -i test/with_dummyserver/test_socketlevel.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x CI=1
+ # FIXME: get tornado ported
+ # please keep in sync with BDEPEND!
+ has "${EPYTHON}" python3.{6..10} || continue
+
+ local deselect=(
+ # TODO?
+ test/with_dummyserver/test_socketlevel.py::TestSocketClosing::test_timeout_errors_cause_retries
+ )
+
+ epytest ${deselect[@]/#/--deselect }
+}