summaryrefslogtreecommitdiff
path: root/dev-python/urllib3
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-python/urllib3
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-python/urllib3')
-rw-r--r--dev-python/urllib3/Manifest6
-rw-r--r--dev-python/urllib3/metadata.xml3
-rw-r--r--dev-python/urllib3/urllib3-1.24.2.ebuild32
-rw-r--r--dev-python/urllib3/urllib3-1.25.7.ebuild74
4 files changed, 92 insertions, 23 deletions
diff --git a/dev-python/urllib3/Manifest b/dev-python/urllib3/Manifest
index 6531004b6923..7fd61626a4e7 100644
--- a/dev-python/urllib3/Manifest
+++ b/dev-python/urllib3/Manifest
@@ -1,3 +1,5 @@
DIST urllib3-1.24.2.tar.gz 230699 BLAKE2B 9c2f2be8fa743f542493d75072c02423d1bd40189561fa0ea393a8a2515b24da9a2a383aeec35b55bdd2a9954d3d585450d759548358ed91ecfdb9ec03d391b6 SHA512 9939e9e7c4da30b5effb334969cd835c9d0404a136761098203c699570aab02e63fb3f1b4ab680def0bc0906fabe5f0782ab94cf3095ff10ccf9b3c371653cf2
-EBUILD urllib3-1.24.2.ebuild 1786 BLAKE2B 5ce80fe396cd213c61ea7fec2c4b73d6329ef6b2cc1d3f6ecb81e70bfeb6d15fd6c427434b7d6eac17844e718c448f1674906e5a60c4dc17ef5ee3f7ecd7b88b SHA512 2804f70bfa94badad848365582df657efee48b4f0abf2efc960f26b048a7a2da3f75711d88a2dda9d17927b8c10aceb8deec146e7d5140e5b0a8223ab0d67276
-MISC metadata.xml 376 BLAKE2B 2e9ba1b23bd9ab2770d23ce9bdf21f4083f46184c22d1dc0bd449b6605c24a2ef0168e1503327b549ba55e81b7bb52fe5f73fa375f06f3c64fabfac6cf5a9d77 SHA512 97d216a4841d8c78655c923060a0040b75fbb2d19a42e51081fc63a4af80514db5abf09a02706cc52387ab7ac72e964f947f1ded50bcc7f8fae6d022d5353543
+DIST urllib3-1.25.7.tar.gz 264636 BLAKE2B 32ee47df52e0d164865400ecb5f0b65d3640173b53e1d9cf8f2dbdec46ac34d56ca66991ab719d9fafb8d49440630a3318312a925f11e3c6b8d26cfa72600c4a SHA512 e43c1b7893488b77a38a9fdcfc9760ceea72c53cf176eb8e4d1d9990732c5c1936f85c653a646eaadb3eaf72a99ccdbb5023430b97beca6458b868095005eac2
+EBUILD urllib3-1.24.2.ebuild 1554 BLAKE2B 665d5b88df7b7d39792a5f37d172adca0cec998de0dbd4e08363e268e904b7817e77792c8cc2295a4558ce6bca3d830aa08bd024be3ae6baad6ad77155356b86 SHA512 28256083feaea0b450c8a31af3ee072f18869419bb499dc05ed1c388b2f9c422100f26cec88ac8e59b2da664043583ac94d89d58f59c0c626d211fbc1c5ce3f7
+EBUILD urllib3-1.25.7.ebuild 2234 BLAKE2B 5dd2199324d474ecf3d10aad35942753ab1d753b0dc6146617206b6da58b68539e714e4657c89b4f4c674930107f544218c1c2d822c070641a7761779a905c84 SHA512 ac74f582b27b96d7e1eafd35b350c04df1109fcb62d80d978dd43c8f937bb8d84806f0d1013f910cdf3985c659dcbe785b6151ca257b3a6890e031154a2f4b7d
+MISC metadata.xml 462 BLAKE2B fa1a23ff540c36b4d00a665f92e4fbc3651ef0d91669c3181b01c6caa3c0c2824ae5ad498c784e13b2b6bbd1763a6eda891385ac584c8657843d61eed03ee952 SHA512 b82fc435e84e67e5536dde9edcd40644706eec6198a65233db5e43f20027ecf70a827f33f7d6b34095151ec7d33b6935bd16022355ac2ba87657185d35210aa0
diff --git a/dev-python/urllib3/metadata.xml b/dev-python/urllib3/metadata.xml
index de0d93deed28..d6e5a01e0df0 100644
--- a/dev-python/urllib3/metadata.xml
+++ b/dev-python/urllib3/metadata.xml
@@ -5,6 +5,9 @@
<email>python@gentoo.org</email>
<name>Python</name>
</maintainer>
+ <use>
+ <flag name="brotli">Enable support for brotli compression</flag>
+ </use>
<upstream>
<remote-id type="pypi">urllib3</remote-id>
<remote-id type="github">shazow/urllib3</remote-id>
diff --git a/dev-python/urllib3/urllib3-1.24.2.ebuild b/dev-python/urllib3/urllib3-1.24.2.ebuild
index fcfe9c27b1a7..cf59c0ffa92f 100644
--- a/dev-python/urllib3/urllib3-1.24.2.ebuild
+++ b/dev-python/urllib3/urllib3-1.24.2.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy{,3} )
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
PYTHON_REQ_USE="ssl(+)"
inherit distutils-r1
@@ -15,8 +15,8 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc test"
-#RESTRICT="test"
+IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="
>=dev-python/PySocks-1.5.6[${PYTHON_USEDEP}]
@@ -32,16 +32,13 @@ DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
${RDEPEND}
- >=www-servers/tornado-4.2.1[$(python_gen_usedep 'python*')]
- dev-python/pytest[${PYTHON_USEDEP}]
- )
- doc? (
dev-python/mock[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ >=www-servers/tornado-4.2.1[$(python_gen_usedep python{2_7,3_{5,6,7}})]
)
"
-# Testsuite written requiring mock to be installed under all Cpythons
+distutils_enable_sphinx docs
python_prepare_all() {
# skip appengine tests
@@ -50,18 +47,11 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
-python_compile_all() {
- use doc && emake -C docs SPHINXOPTS= html
-}
-
python_test() {
# FIXME: get tornado ported
- if [[ ${EPYTHON} == python* ]]; then
- py.test -v || die "Tests fail with ${EPYTHON}"
- fi
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
+ case ${EPYTHON} in
+ python2*|python3.[567])
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+ ;;
+ esac
}
diff --git a/dev-python/urllib3/urllib3-1.25.7.ebuild b/dev-python/urllib3/urllib3-1.25.7.ebuild
new file mode 100644
index 000000000000..036868ec5be8
--- /dev/null
+++ b/dev-python/urllib3/urllib3-1.25.7.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+PYTHON_REQ_USE="ssl(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP library with thread-safe connection pooling, file post, and more"
+HOMEPAGE="https://github.com/shazow/urllib3"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="brotli test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/PySocks-1.5.6[${PYTHON_USEDEP}]
+ !~dev-python/PySocks-1.5.7[${PYTHON_USEDEP}]
+ <dev-python/PySocks-2.0[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-1.3.4[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.14[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.0.0[${PYTHON_USEDEP}]
+ virtual/python-ipaddress[${PYTHON_USEDEP}]
+ brotli? ( dev-python/brotlipy[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/brotlipy[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ >=dev-python/trustme-0.5.3[${PYTHON_USEDEP}]
+ >=www-servers/tornado-4.2.1[$(python_gen_usedep python{2_7,3_{5,6,7}})]
+ )
+"
+
+distutils_enable_sphinx docs
+
+python_prepare_all() {
+ # tests requiring a route to be present
+ sed -e 's:test_enhanced_timeout:_&:' \
+ -e 's:test_https_timeout:_&:' \
+ -i test/with_dummyserver/test_https.py || die
+ sed -e 's:test_https_proxy_.*timeout:_&:' \
+ -i test/with_dummyserver/test_proxy_poolmanager.py || die
+ # no clue why those fail, might be tornado's fault, might be just
+ # very flaky
+ sed -e 's:test_client_no_intermediate:_&:' \
+ -i test/with_dummyserver/test_https.py || die
+ sed -e 's:test_cross_host_redirect:_&:' \
+ -e 's:test_cross_protocol_redirect:_&:' \
+ -e 's:test_basic_ipv6_proxy:_&:' \
+ -i test/with_dummyserver/test_proxy_poolmanager.py || die
+ sed -e 's:test_connection_closed_on_read_timeout_preload_false:_&:' \
+ -i test/with_dummyserver/test_socketlevel.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # FIXME: get tornado ported
+ case ${EPYTHON} in
+ python2*|python3.[567])
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+ ;;
+ esac
+}