summaryrefslogtreecommitdiff
path: root/dev-python/urllib3
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-python/urllib3
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-python/urllib3')
-rw-r--r--dev-python/urllib3/Manifest4
-rw-r--r--dev-python/urllib3/urllib3-1.24.2.ebuild11
-rw-r--r--dev-python/urllib3/urllib3-1.25.7.ebuild17
3 files changed, 18 insertions, 14 deletions
diff --git a/dev-python/urllib3/Manifest b/dev-python/urllib3/Manifest
index 7fd61626a4e7..3080ee796f54 100644
--- a/dev-python/urllib3/Manifest
+++ b/dev-python/urllib3/Manifest
@@ -1,5 +1,5 @@
DIST urllib3-1.24.2.tar.gz 230699 BLAKE2B 9c2f2be8fa743f542493d75072c02423d1bd40189561fa0ea393a8a2515b24da9a2a383aeec35b55bdd2a9954d3d585450d759548358ed91ecfdb9ec03d391b6 SHA512 9939e9e7c4da30b5effb334969cd835c9d0404a136761098203c699570aab02e63fb3f1b4ab680def0bc0906fabe5f0782ab94cf3095ff10ccf9b3c371653cf2
DIST urllib3-1.25.7.tar.gz 264636 BLAKE2B 32ee47df52e0d164865400ecb5f0b65d3640173b53e1d9cf8f2dbdec46ac34d56ca66991ab719d9fafb8d49440630a3318312a925f11e3c6b8d26cfa72600c4a SHA512 e43c1b7893488b77a38a9fdcfc9760ceea72c53cf176eb8e4d1d9990732c5c1936f85c653a646eaadb3eaf72a99ccdbb5023430b97beca6458b868095005eac2
-EBUILD urllib3-1.24.2.ebuild 1554 BLAKE2B 665d5b88df7b7d39792a5f37d172adca0cec998de0dbd4e08363e268e904b7817e77792c8cc2295a4558ce6bca3d830aa08bd024be3ae6baad6ad77155356b86 SHA512 28256083feaea0b450c8a31af3ee072f18869419bb499dc05ed1c388b2f9c422100f26cec88ac8e59b2da664043583ac94d89d58f59c0c626d211fbc1c5ce3f7
-EBUILD urllib3-1.25.7.ebuild 2234 BLAKE2B 5dd2199324d474ecf3d10aad35942753ab1d753b0dc6146617206b6da58b68539e714e4657c89b4f4c674930107f544218c1c2d822c070641a7761779a905c84 SHA512 ac74f582b27b96d7e1eafd35b350c04df1109fcb62d80d978dd43c8f937bb8d84806f0d1013f910cdf3985c659dcbe785b6151ca257b3a6890e031154a2f4b7d
+EBUILD urllib3-1.24.2.ebuild 1546 BLAKE2B 39803592372309905dc6371995be59211b4b94e5fafcc655822be8377acb78ea5afc6af7b2324be364e99ad9903c9ea4708cfe7e22071b868aecc7a4a6a8a389 SHA512 0e968b1b8d9f92fa5874b5cad6db3cf921d7f12dff271d45c5a7549584920e56f8b5b87b43cc24a9b51f2765ce0969832c24c0b331a908dbf73d4596fe3ee9ac
+EBUILD urllib3-1.25.7.ebuild 2255 BLAKE2B 84acdca971d5a9fc383322ae91f2883655b7de7a24c2e3bfc60637f9ff92dddda45a63ec72fa3d3736b678639ced3761964b5c5ca7d6f0b333c045489d235e4c SHA512 f998e4723410b7516dee1e64805146a20c3ef2a5b9dcdf5d0556b529af04b13535694205ecf3ceb1c6d1086ad27a52810980c5f7322cc57c6248c710e0b77761
MISC metadata.xml 462 BLAKE2B fa1a23ff540c36b4d00a665f92e4fbc3651ef0d91669c3181b01c6caa3c0c2824ae5ad498c784e13b2b6bbd1763a6eda891385ac584c8657843d61eed03ee952 SHA512 b82fc435e84e67e5536dde9edcd40644706eec6198a65233db5e43f20027ecf70a827f33f7d6b34095151ec7d33b6935bd16022355ac2ba87657185d35210aa0
diff --git a/dev-python/urllib3/urllib3-1.24.2.ebuild b/dev-python/urllib3/urllib3-1.24.2.ebuild
index cf59c0ffa92f..19eed900a555 100644
--- a/dev-python/urllib3/urllib3-1.24.2.ebuild
+++ b/dev-python/urllib3/urllib3-1.24.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
PYTHON_REQ_USE="ssl(+)"
inherit distutils-r1
@@ -19,8 +19,7 @@ IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="
- >=dev-python/PySocks-1.5.6[${PYTHON_USEDEP}]
- !~dev-python/PySocks-1.5.7[${PYTHON_USEDEP}]
+ >=dev-python/PySocks-1.5.8[${PYTHON_USEDEP}]
<dev-python/PySocks-2.0[${PYTHON_USEDEP}]
dev-python/certifi[${PYTHON_USEDEP}]
>=dev-python/cryptography-1.3.4[${PYTHON_USEDEP}]
@@ -38,7 +37,9 @@ DEPEND="
)
"
-distutils_enable_sphinx docs
+distutils_enable_sphinx docs \
+ dev-python/alabaster \
+ dev-python/mock
python_prepare_all() {
# skip appengine tests
diff --git a/dev-python/urllib3/urllib3-1.25.7.ebuild b/dev-python/urllib3/urllib3-1.25.7.ebuild
index 036868ec5be8..7d7b50ac8af2 100644
--- a/dev-python/urllib3/urllib3-1.25.7.ebuild
+++ b/dev-python/urllib3/urllib3-1.25.7.ebuild
@@ -1,15 +1,15 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
PYTHON_REQ_USE="ssl(+)"
inherit distutils-r1
DESCRIPTION="HTTP library with thread-safe connection pooling, file post, and more"
-HOMEPAGE="https://github.com/shazow/urllib3"
+HOMEPAGE="https://github.com/urllib3/urllib3"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
@@ -19,8 +19,7 @@ IUSE="brotli test"
RESTRICT="!test? ( test )"
RDEPEND="
- >=dev-python/PySocks-1.5.6[${PYTHON_USEDEP}]
- !~dev-python/PySocks-1.5.7[${PYTHON_USEDEP}]
+ >=dev-python/PySocks-1.5.8[${PYTHON_USEDEP}]
<dev-python/PySocks-2.0[${PYTHON_USEDEP}]
dev-python/certifi[${PYTHON_USEDEP}]
>=dev-python/cryptography-1.3.4[${PYTHON_USEDEP}]
@@ -37,11 +36,15 @@ BDEPEND="
dev-python/mock[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
>=dev-python/trustme-0.5.3[${PYTHON_USEDEP}]
- >=www-servers/tornado-4.2.1[$(python_gen_usedep python{2_7,3_{5,6,7}})]
+ $(python_gen_cond_dep '
+ >=www-servers/tornado-4.2.1[${PYTHON_USEDEP}]
+ ' python{2_7,3_{5,6,7}})
)
"
-distutils_enable_sphinx docs
+distutils_enable_sphinx docs \
+ dev-python/alabaster \
+ dev-python/mock
python_prepare_all() {
# tests requiring a route to be present