summaryrefslogtreecommitdiff
path: root/dev-python/url-normalize
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-python/url-normalize
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-python/url-normalize')
-rw-r--r--dev-python/url-normalize/Manifest3
-rw-r--r--dev-python/url-normalize/metadata.xml11
-rw-r--r--dev-python/url-normalize/url-normalize-1.4.3.ebuild30
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/url-normalize/Manifest b/dev-python/url-normalize/Manifest
new file mode 100644
index 000000000000..795dd068178f
--- /dev/null
+++ b/dev-python/url-normalize/Manifest
@@ -0,0 +1,3 @@
+DIST url-normalize-1.4.3.gh.tar.gz 8478 BLAKE2B 2f15a597642626653c96f378b67794819645918473d17faad18187abe35bf7892b11c0bc78451e78f1146389beb3a6470fb3ea1610e60157fee7fbadd9863614 SHA512 46eaa1753b37e89d56cb19818144a7cf5b38653811720eb506732c35bb3732ef0c556420b22a9ee2c08e70e5b408aab7f44cea5e15d1ebe3d717c0c77706bfb8
+EBUILD url-normalize-1.4.3.ebuild 659 BLAKE2B 61ab5f8e8b0c99c99c8f96c09c5a3092b2dc1374186ef8facbe1abeb0b6ecf7b391124a188a257b65a34bc7c462bee94d540cc415a2cef34ed17eab4a9e85e52 SHA512 36d996094cd44789077b3a06419c635241f2c5c661bc703ba3411ab4aaaf1e5a043757ff2a490bb2a9661fce53fdb2464631fc5423953c071da7c6eb399ffc51
+MISC metadata.xml 355 BLAKE2B a205425ff06928adf5c3e29d13c2e740484b29468a9c440f89c902a9df7d3d6e10906c6b1f854455cc57877948f3d49739b2b1fc38f65c4cf6bfe46c4e1795bf SHA512 f1e9946b44282eda2f21f8b6edd9dd8264109d356826d96e9baf4cb20de68e544026825bc6cb7328b5f4c1f374ac8770a3d9be575388d4ca474adcc3ca452197
diff --git a/dev-python/url-normalize/metadata.xml b/dev-python/url-normalize/metadata.xml
new file mode 100644
index 000000000000..601aeb3c280e
--- /dev/null
+++ b/dev-python/url-normalize/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">niksite/url-normalize</remote-id>
+ <remote-id type="pypi">url-normalize</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/url-normalize/url-normalize-1.4.3.ebuild b/dev-python/url-normalize/url-normalize-1.4.3.ebuild
new file mode 100644
index 000000000000..79a18fe1ba92
--- /dev/null
+++ b/dev-python/url-normalize/url-normalize-1.4.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="URL normalization for Python"
+HOMEPAGE="
+ https://github.com/niksite/url-normalize/
+ https://pypi.org/project/url-normalize/"
+SRC_URI="
+ https://github.com/niksite/url-normalize/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # remove problematic pytest options
+ rm tox.ini || die
+ distutils-r1_src_prepare
+}