summaryrefslogtreecommitdiff
path: root/dev-python/uri_template
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-python/uri_template
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-python/uri_template')
-rw-r--r--dev-python/uri_template/Manifest3
-rw-r--r--dev-python/uri_template/metadata.xml20
-rw-r--r--dev-python/uri_template/uri_template-1.1.0.ebuild23
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/uri_template/Manifest b/dev-python/uri_template/Manifest
new file mode 100644
index 000000000000..22420c876d9b
--- /dev/null
+++ b/dev-python/uri_template/Manifest
@@ -0,0 +1,3 @@
+DIST uri_template-v1.1.0.tar.gz 18014 BLAKE2B 01ac4439b6661d0d1e7adb5b5ebcc594497cdaeef24b33cbfc8a26f607e779a72ae20838dbbcce28278886c87df475adfd53c73287a4768d848f65b95ba2ce58 SHA512 b6d34931e750acc6c160e7157fc000984acc099023e9794163777679cbe706b8a646bab89e82171c0318827b7a7b9cfcfb997768120cabcf36e7982214321665
+EBUILD uri_template-1.1.0.ebuild 633 BLAKE2B 03e897c036d01e568d282cf88af4cf6aa3581f7c1ac050ef1ad0d216372df807d7f89f1bb0d784fa570af7195b0b1230dd3af9a43670c1d57c8ddcbeb352829e SHA512 471769f23935ba3194dce78436b59deb845dcab374ba80daa6edf07eeab66e5496d7bab699ea05476105db024e3e30eb695ffcc55ad86f8c354c21b4104d1ea8
+MISC metadata.xml 595 BLAKE2B 06f55493da74b24bd7ee6266accaa73b33e3f48a1d7d0f176a6278231e281fe269e6825f34ad1fa122b6d11ac1f66b21696410ae51d0917868f02d2ea57814ec SHA512 148737f47b030bb76659503ca70582385c005ffa5168e46ccdcfc8f7729299c38bd3b6b20a875e69690ff1bbf117da61d92f0f4657b97cf172ac358241fd4709
diff --git a/dev-python/uri_template/metadata.xml b/dev-python/uri_template/metadata.xml
new file mode 100644
index 000000000000..582b879aa5bb
--- /dev/null
+++ b/dev-python/uri_template/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>gentoo@chymera.eu</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">uri-template</remote-id>
+ </upstream>
+ <stabilize-allarches/>
+</pkgmetadata>
diff --git a/dev-python/uri_template/uri_template-1.1.0.ebuild b/dev-python/uri_template/uri_template-1.1.0.ebuild
new file mode 100644
index 000000000000..d8cf7ad1ea00
--- /dev/null
+++ b/dev-python/uri_template/uri_template-1.1.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P="${PN}-v${PV}"
+DESCRIPTION="URI Template expansion in strict adherence to RFC 6570"
+HOMEPAGE="https://gitlab.linss.com/open-source/uri_template/"
+SRC_URI="https://gitlab.linss.com/open-source/${PN}/-/archive/v${PV}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~m68k ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+python_test() {
+ "${EPYTHON}" "test.py" || die "Tests fail with ${EPYTHON}."
+}