summaryrefslogtreecommitdiff
path: root/dev-python/unpaddedbase64
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /dev-python/unpaddedbase64
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'dev-python/unpaddedbase64')
-rw-r--r--dev-python/unpaddedbase64/Manifest3
-rw-r--r--dev-python/unpaddedbase64/metadata.xml16
-rw-r--r--dev-python/unpaddedbase64/unpaddedbase64-2.1.0.ebuild24
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/unpaddedbase64/Manifest b/dev-python/unpaddedbase64/Manifest
new file mode 100644
index 000000000000..0d98428c8d35
--- /dev/null
+++ b/dev-python/unpaddedbase64/Manifest
@@ -0,0 +1,3 @@
+DIST unpaddedbase64-2.1.0.gh.tar.gz 5869 BLAKE2B c53dae277b5e69f6d905724d5b212050100286217fd236f9e1a6c344ff479d4c38ee9634a544b2e693522c04a9bbfdaeebbb2ac79904089d91e4d6c18b6995e8 SHA512 9c7c2dd6e52ffae2bf076ccf9e1e2ea9a53cbef083c23f640cc2f3f5c49ceee0c92c8abe0469e10d80b7c9e74d69b2b06111b1c4204b4cb1788ee3fffcea6e11
+EBUILD unpaddedbase64-2.1.0.ebuild 546 BLAKE2B d26fad580e0d736fa1f90516a95eb50a633a4e9feb33e55c3e6521c22b31b2cd048a30155f5faf1fd5e62975b8c399fd51054449f625ef86698e35ff6a6dbb20 SHA512 44f02fc712dd887a8f848619cd76d2d4c4b951c71bc236a7393854536118ec98699f7e91e26f9bf45aef07f234b47bd9845b0831ce937f2d75624a28e35d8950
+MISC metadata.xml 540 BLAKE2B 1898130f21204bc79295999a55a50813699ff59e2d3f42dd0cc325be2b6653e5dadc895b072055d8c98d245e6eb9f68570ac24b8002f22027c720d872a893683 SHA512 6026ff3cd1f74a7b4254cef463285dfcf5b79c2a7433fa699b2eab31ac02a340559a1c2297179fa48e5263d9f864a30dd195953890847b97bec483949c570a8a
diff --git a/dev-python/unpaddedbase64/metadata.xml b/dev-python/unpaddedbase64/metadata.xml
new file mode 100644
index 000000000000..9b1cf451b586
--- /dev/null
+++ b/dev-python/unpaddedbase64/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>arkamar@atlas.cz</email>
+ <name>Petr Vaněk</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">unpaddedbase64</remote-id>
+ <remote-id type="github">matrix-org/python-unpaddedbase64</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/unpaddedbase64/unpaddedbase64-2.1.0.ebuild b/dev-python/unpaddedbase64/unpaddedbase64-2.1.0.ebuild
new file mode 100644
index 000000000000..d8e6ae6fb108
--- /dev/null
+++ b/dev-python/unpaddedbase64/unpaddedbase64-2.1.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Unpadded Base64"
+HOMEPAGE="
+ https://github.com/matrix-org/python-unpaddedbase64
+ https://pypi.python.org/pypi/unpaddedbase64
+"
+SRC_URI="https://github.com/matrix-org/python-unpaddedbase64/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+S="${WORKDIR}/python-${P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests unittest