summaryrefslogtreecommitdiff
path: root/dev-python/unidiff/unidiff-0.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-python/unidiff/unidiff-0.6.0.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-python/unidiff/unidiff-0.6.0.ebuild')
-rw-r--r--dev-python/unidiff/unidiff-0.6.0.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/unidiff/unidiff-0.6.0.ebuild b/dev-python/unidiff/unidiff-0.6.0.ebuild
new file mode 100644
index 000000000000..9827339cdb5e
--- /dev/null
+++ b/dev-python/unidiff/unidiff-0.6.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="Unified diff parsing/metadata extraction library"
+HOMEPAGE="https://github.com/matiasb/python-unidiff https://pypi.org/project/unidiff/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+distutils_enable_tests unittest