summaryrefslogtreecommitdiff
path: root/dev-python/unearth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-15 13:18:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-15 13:18:00 +0000
commitb9d13f23ed10bb803607f6ef67f0df2f078aa70f (patch)
tree6ff7cd69abb13870927f740d32794bde212eefe7 /dev-python/unearth
parent804e8874f39a664f97becd43e96d0cced9c58d50 (diff)
gentoo auto-resync : 15:01:2024 - 13:18:00
Diffstat (limited to 'dev-python/unearth')
-rw-r--r--dev-python/unearth/Manifest2
-rw-r--r--dev-python/unearth/unearth-0.13.0.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/unearth/Manifest b/dev-python/unearth/Manifest
index 605ae32367ff..72a8a005d5bf 100644
--- a/dev-python/unearth/Manifest
+++ b/dev-python/unearth/Manifest
@@ -1,3 +1,5 @@
DIST unearth-0.12.1.tar.gz 280628 BLAKE2B 2f96c818f5744b228d11d81fac8fb69da4df685b221f3a77424a1eb1d584e154798974ad4548c6f4264faa98f52cddeb94249e1c7e21136c50c08d97446149b6 SHA512 f726562191a3f2b9c189d16223b86307d79f0ca9e251c155e7acbc92160bed834c78064fbc5d745cd90b84ccd6eb2a24c737018fd670474921db0c7d15480576
+DIST unearth-0.13.0.tar.gz 280537 BLAKE2B 92e8cfd42c36d067eccba594ef6e510491156bb4e85d66ab0c1050029be3acf3308c21581d82a3ffd1982d1c8eb966d0be68d1fb8739621b52aa9e7073fd5963 SHA512 48bcdd2e61ffc6580ce19d0124e43aab0411efa913801cd74365ddefa3cec50eb0742997fd6359b6191a00314964b052ebf8d3ea5a173d37bc2cfedc1d030408
EBUILD unearth-0.12.1.ebuild 825 BLAKE2B 698b21cf553d4e66ef9139fb48fa50d5f1885610076303ad36aa72d4d5c9abb98abc721caf7a333b406b6b84640c5d2c9a84b208d64c426e9292d0d698254d81 SHA512 07bb838ac15234900001b76595bbedb331caf54a90120d3baf356cd07e3b6eec2c6d3a1be02a581d3ad5ffc1a8b91ae811b4169afed97e2377992bb6d387162b
+EBUILD unearth-0.13.0.ebuild 830 BLAKE2B 1dca317bbe176d27df70e3cbf3e5ebe97b819ff85b1452ee17debca9603f151a052ce7f9cfff35d769cde9d8add4e98e4d99abf1e7bb4b17bdb67a149e135c7c SHA512 cb87fe7d571392dca3fb1cb3743b9b748a61076055b0af3234932548a6d7706a87e736e9c352fd9859ca61c838bc3e91c5acf2d6a6d47265866e78beff156a7a
MISC metadata.xml 480 BLAKE2B 489aab9c338887392b943b48593bd9d752083d82fcf89a419e3677f2d24939af51cabe16641c3a16942f9658fe79f804af61cffc807cdeb909d44a6cff5ced5b SHA512 9fe2154826a2399f5570fa150445220f7490e10741275f77791b1d29522336912812e3f8905c026cb748845d2f2a005196185db6576708b47f1cdf582216182f
diff --git a/dev-python/unearth/unearth-0.13.0.ebuild b/dev-python/unearth/unearth-0.13.0.ebuild
new file mode 100644
index 000000000000..ddcdfe66abda
--- /dev/null
+++ b/dev-python/unearth/unearth-0.13.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A utility to fetch and download python packages"
+HOMEPAGE="
+ https://pypi.org/project/unearth/
+ https://github.com/frostming/unearth/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-httpserver[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/requests-wsgi-adapter[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_httpserver
+}