summaryrefslogtreecommitdiff
path: root/dev-python/unearth/unearth-0.12.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-20 15:52:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-20 15:52:41 +0100
commitb3830a745865c7d85daf3317603ad23dac6434da (patch)
tree8bacb840498f00754dc51ec2ab76bb175f52fc58 /dev-python/unearth/unearth-0.12.0.ebuild
parent547caa904733bc2a3ac112415990a114ecbe8824 (diff)
gentoo auto-resync : 20:10:2023 - 15:52:41
Diffstat (limited to 'dev-python/unearth/unearth-0.12.0.ebuild')
-rw-r--r--dev-python/unearth/unearth-0.12.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/unearth/unearth-0.12.0.ebuild b/dev-python/unearth/unearth-0.12.0.ebuild
new file mode 100644
index 000000000000..9c0635d2317b
--- /dev/null
+++ b/dev-python/unearth/unearth-0.12.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A utility to fetch and download python packages"
+HOMEPAGE="
+ https://pypi.org/project/unearth/
+ https://github.com/frostming/unearth/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-httpserver[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/requests-wsgi-adapter[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_httpserver
+}