summaryrefslogtreecommitdiff
path: root/dev-python/unearth/unearth-0.11.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-25 10:31:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-25 10:31:10 +0000
commit2900e684ae4bdce1f20652587728095cd01a30a1 (patch)
treedb7b5054b7d0de362a2960a0a7268ffc37b8e1f9 /dev-python/unearth/unearth-0.11.2.ebuild
parentff8c6e4babf1a2911b8d61b6bb7e80290355cb70 (diff)
gentoo auto-resync : 25:11:2023 - 10:31:10
Diffstat (limited to 'dev-python/unearth/unearth-0.11.2.ebuild')
-rw-r--r--dev-python/unearth/unearth-0.11.2.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/unearth/unearth-0.11.2.ebuild b/dev-python/unearth/unearth-0.11.2.ebuild
deleted file mode 100644
index 9c0635d2317b..000000000000
--- a/dev-python/unearth/unearth-0.11.2.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=pdm-backend
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="A utility to fetch and download python packages"
-HOMEPAGE="
- https://pypi.org/project/unearth/
- https://github.com/frostming/unearth/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pytest-httpserver[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/requests-wsgi-adapter[${PYTHON_USEDEP}]
- dev-python/trustme[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p pytest_httpserver
-}