summaryrefslogtreecommitdiff
path: root/dev-python/uncompyle6
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/uncompyle6
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/uncompyle6')
-rw-r--r--dev-python/uncompyle6/Manifest3
-rw-r--r--dev-python/uncompyle6/metadata.xml19
-rw-r--r--dev-python/uncompyle6/uncompyle6-2.10.1.ebuild42
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/uncompyle6/Manifest b/dev-python/uncompyle6/Manifest
new file mode 100644
index 000000000000..b62536121b16
--- /dev/null
+++ b/dev-python/uncompyle6/Manifest
@@ -0,0 +1,3 @@
+DIST uncompyle6-2.10.1.tar.gz 831835 BLAKE2B dbde4d8414804d55871d846ad42f9a4859913ee057dcea5f6f19e8104e39d3274e13c86538f3364e6829d2ca9ecd16929143e266a828558e870d0f78d3cdff1b SHA512 5be7c33749f3a2a02494aceebeeb2cb79bf71c39784dbe4e96cf9a5c6f02af89874bc25ba911308f01414e4ae4d9ac445864505c629d41a2c6f8b2eae2197b2b
+EBUILD uncompyle6-2.10.1.ebuild 1012 BLAKE2B 6206026e71807330a56b9718dda9674298569512fd5c6c6aa4b3c781a9b4c574c15329eb9f58342666232b503bd28fbdeec684ae77aeef6e5f59a8ae733f5319 SHA512 b7db2e88d149acd62641e16864bbd778a8eb2b7ef37b6ecee69d9b76a58e3f87ddd917e559884ddc2c492af479534f16861f5eb8523c7dc3a7932b2513b3a17c
+MISC metadata.xml 552 BLAKE2B d617784c64b4907602ad6a9f9f807ae48b98ff6eb15303263f3b6fa2755dce271995dc9f1521849358ef269c4a7eced1227342fd5ef79061d25c1a100e040103 SHA512 1f50ef6b1d9d287a4f2355cc66ef799d3c6c9475c1d931842482a0121d00301266ccf6c9635ed5063a2c2b8e00c770cfd5263645d0a898457c00bfae606f62b5
diff --git a/dev-python/uncompyle6/metadata.xml b/dev-python/uncompyle6/metadata.xml
new file mode 100644
index 000000000000..31972835e1f7
--- /dev/null
+++ b/dev-python/uncompyle6/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dolsen@gentoo.org</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>rb@dustyfeet.com</email>
+ <name>Rocky Bernstein</name>
+ </maintainer>
+ <remote-id type="pypi">uncompyle6</remote-id>
+ <remote-id type="github">rocky/python-uncompyle6</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/uncompyle6/uncompyle6-2.10.1.ebuild b/dev-python/uncompyle6/uncompyle6-2.10.1.ebuild
new file mode 100644
index 000000000000..f1b9c4531e26
--- /dev/null
+++ b/dev-python/uncompyle6/uncompyle6-2.10.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python cross-version byte-code deparser"
+HOMEPAGE="https://github.com/rocky/python-uncompyle6/ https://pypi.org/project/uncompyle6/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/xdis-3.3.1
+ <dev-python/xdis-3.4.0
+ >=dev-python/spark-parser-1.6.1
+ <dev-python/spark-parser-1.7.0"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/nose-1.0[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+}
+
+# only run the recommended "make check" tests
+python_test() {
+ distutils_install_for_testing
+
+ PYTHONPATH="${S}/test:${BUILD_DIR}/lib" \
+ emake check || die "Tests failed under ${EPYTHON}"
+}