summaryrefslogtreecommitdiff
path: root/dev-python/uncertainties
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/uncertainties
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/uncertainties')
-rw-r--r--dev-python/uncertainties/Manifest4
-rw-r--r--dev-python/uncertainties/metadata.xml22
-rw-r--r--dev-python/uncertainties/uncertainties-3.0.1.ebuild42
3 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/uncertainties/Manifest b/dev-python/uncertainties/Manifest
new file mode 100644
index 000000000000..77b759b1e45a
--- /dev/null
+++ b/dev-python/uncertainties/Manifest
@@ -0,0 +1,4 @@
+DIST uncertainties-3.0.1.tar.gz 225752 SHA256 de0765cac6911e5afa93ee941063a07b4a98dbd9c314c5eea4ab14bfff0054a4 SHA512 d4b2a905665c46224586f5f9702ad9e69580fc5afe8c6c045b04141fdc54e0c402cdee033ee0ee7055823b922bd33c732b3066453876509d45add15abf9d85f5 WHIRLPOOL f203fc2fdae59775dcb57db81ffb3ff02befd50676251c218934fa15f7c7df047d97282d90ac5f9f658d040b173e2aad8fed5130c8158c39fadd7d13b80036df
+EBUILD uncertainties-3.0.1.ebuild 980 SHA256 2ab5bed34c85244add8a5c0fa4ea600a08fb813d041187c6b1e7fd75f34208cf SHA512 2c1eb1dc0743895ea27f2fa6b9a95487e0ea2b7b3cf39c1c9af1f37a1aae0c4cd737a12b595bfbe438c27a12b42b437e63c6ec1a84a8c25fc006b9421085a490 WHIRLPOOL 3c9a1166fcb38b9b8e40ae34d5815b127cb053949d3582ef1ff82144a778ea3f01fa1214f0b291a5e925379f7bb621ece8c67feaea84a49e54da9830c7f5702a
+MISC ChangeLog 333 SHA256 8c05283b1802c3c979dc645578c7a09ff93f57b0ef16bf4add404513ebbcec8c SHA512 143e8a87f25028e709006012595a6ad4b99410670349019a2c9ae5c5755521b152507926ac5c5c76ac7c6cbcb3fc5350f2119ef9c64181da3db0516edfac0f86 WHIRLPOOL 7048b8568320cd27563dbfd39df9793d1c2788725cd08509fbd804488b676a95561f10e99bc1a066f3b19f275cd52db8ca77020c903c0fb92a4758beeae14c54
+MISC metadata.xml 859 SHA256 502e8cc55f4543dd16cbf76a5c8510c4b3ff928b40216847d5ff2e76a8b11876 SHA512 833af2fd16f097d61942c7f9323d8e38688eead6d5d10ae8e7f2547c950cd53ab6ce28f434d2c1bb2f15b71ec55bfc30b8bd53a94a0c5f02e824e3ecb08ecc89 WHIRLPOOL e91ebe67800692ab273a96963ca55a30a428f57a0aea11e901ee9c5eb3a909f42657a54bdf55f922aafce238995448f7d4b976d6c02c993944adf68115c72d81
diff --git a/dev-python/uncertainties/metadata.xml b/dev-python/uncertainties/metadata.xml
new file mode 100644
index 000000000000..a24d72178d1b
--- /dev/null
+++ b/dev-python/uncertainties/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ uncertainties is a Python module, which allows calculations such as
+ .
+ (0.2 +/- 0.01) * 2 = 0.4 +/- 0.02
+ .
+ to be performed transparently; much more complex mathematical expressions
+ involving numbers with uncertainties can also be evaluated transparently.
+ Correlations between expressions are correctly taken into account; x-x is
+ thus exactly zero, for instance. The uncertainties produced by this module
+ are what is predicted by error propagation theory.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">uncertainties</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/uncertainties/uncertainties-3.0.1.ebuild b/dev-python/uncertainties/uncertainties-3.0.1.ebuild
new file mode 100644
index 000000000000..c50978aff237
--- /dev/null
+++ b/dev-python/uncertainties/uncertainties-3.0.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for calculations with uncertainties"
+HOMEPAGE="https://pythonhosted.org/uncertainties/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+ppython_compile_all() {
+ if use doc; then
+ PYTHONPATH="${BUILD_DIR}"/lib esetup.py build_sphinx
+ fi
+}
+
+python_compile_all() {
+ use doc && "${PYTHON}" setup.py build_sphinx
+}
+
+python_test() {
+ esetup.py nosetests -sv || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( build/sphinx/html/. )
+ distutils-r1_python_install_all
+}