summaryrefslogtreecommitdiff
path: root/dev-python/ukkonen
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-python/ukkonen
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-python/ukkonen')
-rw-r--r--dev-python/ukkonen/Manifest3
-rw-r--r--dev-python/ukkonen/metadata.xml11
-rw-r--r--dev-python/ukkonen/ukkonen-1.0.0.ebuild27
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/ukkonen/Manifest b/dev-python/ukkonen/Manifest
new file mode 100644
index 000000000000..593ac2ad20a3
--- /dev/null
+++ b/dev-python/ukkonen/Manifest
@@ -0,0 +1,3 @@
+DIST ukkonen-1.0.0.gh.tar.gz 4541 BLAKE2B c93623523fc57b27bb68a2bb41fca51a967910c4936140bee628b4270e343e7902b9e7a6fb85bc89c197e2b0c6897c2d3f788886541bc8b6b7758a6f158a5c6c SHA512 87e3078e8cd4807af3f91c1be7766454705b077cb093eadac34d1af4d56b458813c1062eb086232bffa43b5ca7aa07ed88192e56dacce96c6781f16129111d79
+EBUILD ukkonen-1.0.0.ebuild 625 BLAKE2B a8dadfe11d9d1a4eb8e927629c579f7512664f366c3cc4f2d4f2d60668f582205aeab77eeea2ad526a9319545fda87536ee38cf6186fbd1fa63efb75d7958f5d SHA512 139930ed1b1e9c748a0c4a6cf4e702e1556768d3ad82495dba99eb6e8f76994829c2b7a864da7fcd0dab25f88e1e2e132943d90fac8c715de36743ced3a0e86f
+MISC metadata.xml 345 BLAKE2B 316467291e5dee76baeaaed62a17e6c5e6216dc8eec5ffbd0fe7465e8c70cd47a2b1ec0c15f082c4bc17a1794ebfec01ab65d6260b0bb6d7af9830e0233e379b SHA512 891214a8416169a7cffc49b0682d1e2e471da4683a7dd528da6d75045d11d16c18fe4bc9ad0c883fbe4a877878e7a0434af1244353910ccc3aa1c193fc2d7a16
diff --git a/dev-python/ukkonen/metadata.xml b/dev-python/ukkonen/metadata.xml
new file mode 100644
index 000000000000..d4ba35cb5b1c
--- /dev/null
+++ b/dev-python/ukkonen/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">ukkonen</remote-id>
+ <remote-id type="github">asottile/ukkonen</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/ukkonen/ukkonen-1.0.0.ebuild b/dev-python/ukkonen/ukkonen-1.0.0.ebuild
new file mode 100644
index 000000000000..a4cc21241192
--- /dev/null
+++ b/dev-python/ukkonen/ukkonen-1.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Implementation of bounded Levenshtein distance (Ukkonen)"
+HOMEPAGE="
+ https://pypi.org/project/ukkonen/
+ https://github.com/asottile/ukkonen/"
+SRC_URI="
+ https://github.com/asottile/ukkonen/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/cffi[${PYTHON_USEDEP}]
+ ' 'python*')"
+BDEPEND=${RDEPEND}
+
+distutils_enable_tests pytest