summaryrefslogtreecommitdiff
path: root/dev-python/ujson/ujson-1.35.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/ujson/ujson-1.35.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/ujson/ujson-1.35.ebuild')
-rw-r--r--dev-python/ujson/ujson-1.35.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-python/ujson/ujson-1.35.ebuild b/dev-python/ujson/ujson-1.35.ebuild
deleted file mode 100644
index f09734949f28..000000000000
--- a/dev-python/ujson/ujson-1.35.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Ultra fast JSON encoder and decoder for Python"
-HOMEPAGE="https://pypi.org/project/ujson/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- $(python_gen_cond_dep 'dev-python/unittest2[${PYTHON_USEDEP}]' -2)
- dev-python/pytz[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-sort_keys-segfault.patch"
- "${FILESDIR}/${P}-use-static-where-possible.patch"
- "${FILESDIR}/${P}-fix-for-overflowing-long.patch"
- "${FILESDIR}/${P}-standard-handling-of-none.patch"
- "${FILESDIR}/${P}-fix-ordering-of-orderdict.patch"
- "${FILESDIR}/${P}-test-depricationwarning.patch"
-)
-
-python_test() {
- "${PYTHON}" tests/tests.py || die
-}