summaryrefslogtreecommitdiff
path: root/dev-python/typogrify
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
commita978c074e4272bb901fbe4a10de0a7b2af574f17 (patch)
tree8c764c1cc0576389ce22abd317bceba71ea5732d /dev-python/typogrify
parent40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (diff)
gentoo resync : 04.05.2021
Diffstat (limited to 'dev-python/typogrify')
-rw-r--r--dev-python/typogrify/Manifest3
-rw-r--r--dev-python/typogrify/metadata.xml14
-rw-r--r--dev-python/typogrify/typogrify-2.0.7.ebuild27
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/typogrify/Manifest b/dev-python/typogrify/Manifest
new file mode 100644
index 000000000000..da2f1cdbfcb6
--- /dev/null
+++ b/dev-python/typogrify/Manifest
@@ -0,0 +1,3 @@
+DIST typogrify-2.0.7.tar.gz 12903 BLAKE2B e08b27a531f21e99d5a35c47c1deb94bc7f67e31a47789ba4750520c893633966b1319a731c81ab2435e7024aea1e8fd0b46a52bbb73a050cdf83a1588644d18 SHA512 6212024a88372f1b14e5932c0541ec4d5a2ada7514c1327dc8f3775cd7adf3372cae0037c4310ed4a03fd0657a91eb4c0d114b74172190f7f84d82908441ddd0
+EBUILD typogrify-2.0.7.ebuild 661 BLAKE2B 9169151c1444166ce7916b73a8730d5a46213edc1b91b71365e07575cf47338e0d7b0f4b028e5f6f8472b66f1813ebe155cdc7bb556c86cefba901c3f4d58c14 SHA512 88d3b6ffe25ca56e783effcd7cf1b151323ffe9a6f2b61a30b189614f0a145f7021e884f54310a848f2af6e732b6b026e8d09b8d6a2fdcfc074fd996e3c25233
+MISC metadata.xml 463 BLAKE2B feb4586174307a87c89200cd8cf12b597cda32c73b9ce945075d68d7e69c37ed06404316a7473f91d278d3b7649d3e1dce347e550be1b19f81c7d06a36111924 SHA512 7d629d2bf2c3d34cc4922be9b27ee09edbce594f52806511b82dcd8bb270572dadd25513cb00d021975c3978f0a9d1dffe79b0874f61179ae970c54d6f2f3029
diff --git a/dev-python/typogrify/metadata.xml b/dev-python/typogrify/metadata.xml
new file mode 100644
index 000000000000..288c408a5ef4
--- /dev/null
+++ b/dev-python/typogrify/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">typogrify</remote-id>
+ <remote-id type="github">mintchaos/typogrify</remote-id>
+ <bugs-to>https://github.com/mintchaos/typogrify/issues/</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/typogrify/typogrify-2.0.7.ebuild b/dev-python/typogrify/typogrify-2.0.7.ebuild
new file mode 100644
index 000000000000..9b24bf19f431
--- /dev/null
+++ b/dev-python/typogrify/typogrify-2.0.7.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Filters for web typography, supporting Django & Jinja templates"
+HOMEPAGE="https://github.com/mintchaos/typogrify/ https://pypi.org/project/typogrify/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ >=dev-python/smartypants-1.8.3[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest --doctest-modules typogrify/filters.py typogrify/packages/titlecase/tests.py
+}