summaryrefslogtreecommitdiff
path: root/dev-python/typeguard/typeguard-3.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-18 19:48:47 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-18 19:48:47 +0100
commit1494784ae35c6fa7b6a92a80dea93265fc54ccd0 (patch)
treedbbb1b83e130750c3a55a4287c3a2ec2bbff7af8 /dev-python/typeguard/typeguard-3.0.2.ebuild
parentee74b33422f15493c315bdacf20da95d5b936d3c (diff)
gentoo auto-resync : 18:06:2023 - 19:48:47
Diffstat (limited to 'dev-python/typeguard/typeguard-3.0.2.ebuild')
-rw-r--r--dev-python/typeguard/typeguard-3.0.2.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/typeguard/typeguard-3.0.2.ebuild b/dev-python/typeguard/typeguard-3.0.2.ebuild
deleted file mode 100644
index 5502867a6a8a..000000000000
--- a/dev-python/typeguard/typeguard-3.0.2.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Run-time type checker for Python"
-HOMEPAGE="
- https://pypi.org/project/typeguard/
- https://github.com/agronholm/typeguard/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- $(python_gen_cond_dep '
- >=dev-python/importlib-metadata-3.6[${PYTHON_USEDEP}]
- ' 3.{8..9})
- $(python_gen_cond_dep '
- >=dev-python/typing-extensions-4.4.0[${PYTHON_USEDEP}]
- ' 3.{8..10})
-"
-BDEPEND="
- >=dev-python/setuptools-scm-6.4[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_IGNORE=(
- # mypy changes results from version to version
- tests/mypy
- )
-
- local -x PYTHONDONTWRITEBYTECODE=
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- # the XFAIL test pass due to some package being installed
- epytest -o xfail_strict=False
-}