summaryrefslogtreecommitdiff
path: root/dev-python/txtorcon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-04 22:13:37 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-04 22:13:37 +0000
commit39ca6159b9ac903dc56818918d9f97bc831f0955 (patch)
treee9b34845be7f96bc244fd239f6dd8090096ce703 /dev-python/txtorcon
parentbc968d15e7f24968eb69567c7f2fca470fdedacd (diff)
gentoo auto-resync : 04:11:2023 - 22:13:37
Diffstat (limited to 'dev-python/txtorcon')
-rw-r--r--dev-python/txtorcon/Manifest2
-rw-r--r--dev-python/txtorcon/txtorcon-23.5.0.ebuild19
2 files changed, 15 insertions, 6 deletions
diff --git a/dev-python/txtorcon/Manifest b/dev-python/txtorcon/Manifest
index f5cf9e56a319..30b6273f406a 100644
--- a/dev-python/txtorcon/Manifest
+++ b/dev-python/txtorcon/Manifest
@@ -1,3 +1,3 @@
DIST txtorcon-23.5.0.gh.tar.gz 394188 BLAKE2B ee63d2815a9b697aa37d27697ef6085dc91e750ba0cad854c8610eed7afcfec9b50cf5aead24f75676e2b0ee39167c50fbebc43a51911a3ebe17eb784b18d31e SHA512 33610c043084273f5dc06b797fff11bb0fccaae14229dbd07286e13e40ebc199594f6e52c64b87e4060e37bcb44bd90ccf7ff7217d923fdb33a581fb95144d56
-EBUILD txtorcon-23.5.0.ebuild 871 BLAKE2B 28aac76a8052e28d87b381eb440f62658f0cdc925e69b55b9f63081470e367f2143e09ea40b84df34a2ffd5ee7d95aaf92e5518409d74c345c3b6726ebf17907 SHA512 2122bb9125e0dfb995d7991a8aacceb65d60c31bed8a94e8cb43d5383d40046fca96a7771def1ef2ef9d6a6d74ac553e5702693fd7cc0c0636d2e3384d1c2f15
+EBUILD txtorcon-23.5.0.ebuild 913 BLAKE2B 7f9368be8a343b8c7206b5ab3f43918e17d401740ed54a9d7b4829908089679e9351dc44cf699c8181956a7918099011dcfd25751be46da306be8e6602732297 SHA512 40cc44666b2834f71901b264e7729abdc149b29c376a17f3394054feaf1e3a0ac62eb16b90b2db562e73e3d3136d0f8dfad4f6addf8abc448b8cce342cc2795a
MISC metadata.xml 398 BLAKE2B 5cff75ef9af25e3c3d1ef95de2d272d6f79c06a0e1101062d06bbc463010dcbf54d0ab2a94eaa049ba5050d53a703039fcf64de9ebc4c704bdc1bb25f909a3c8 SHA512 8c638e5e0e762bd5f2129f0a2696d50c91c304efecc627b4bc15e5f3e4fe811ca7bdfb20ca67546b2d9056cee80e7adbf1489c061df4dd85c94a08005b5acbbc
diff --git a/dev-python/txtorcon/txtorcon-23.5.0.ebuild b/dev-python/txtorcon/txtorcon-23.5.0.ebuild
index a1f17ef91891..0046315727fb 100644
--- a/dev-python/txtorcon/txtorcon-23.5.0.ebuild
+++ b/dev-python/txtorcon/txtorcon-23.5.0.ebuild
@@ -3,14 +3,21 @@
EAPI=8
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1
DESCRIPTION="Twisted-based Tor controller client, with state-tracking abstractions"
-HOMEPAGE="https://txtorcon.readthedocs.org https://pypi.org/project/txtorcon/"
-SRC_URI="https://github.com/meejah/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+HOMEPAGE="
+ https://txtorcon.readthedocs.org/
+ https://github.com/meejah/txtorcon/
+ https://pypi.org/project/txtorcon/
+"
+SRC_URI="
+ https://github.com/meejah/txtorcon/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
LICENSE="MIT"
SLOT="0"
@@ -22,12 +29,14 @@ RDEPEND="
dev-python/incremental[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
dev-python/twisted[ssl,${PYTHON_USEDEP}]
- dev-python/zope-interface[${PYTHON_USEDEP}]"
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+"
BDEPEND="
test? (
sys-process/lsof
dev-python/mock[${PYTHON_USEDEP}]
- )"
+ )
+"
distutils_enable_tests pytest