summaryrefslogtreecommitdiff
path: root/dev-python/twython/twython-3.9.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/twython/twython-3.9.1-r1.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/twython/twython-3.9.1-r1.ebuild')
-rw-r--r--dev-python/twython/twython-3.9.1-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/twython/twython-3.9.1-r1.ebuild b/dev-python/twython/twython-3.9.1-r1.ebuild
new file mode 100644
index 000000000000..6e483bc423d5
--- /dev/null
+++ b/dev-python/twython/twython-3.9.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="An easy way to access Twitter data with Python"
+HOMEPAGE="https://github.com/ryanmcgrath/twython"
+SRC_URI="
+ https://github.com/ryanmcgrath/twython/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/requests-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-oauthlib-0.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/responses[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # tests are largely unmaintained and outdated
+ tests/test_core.py::TwythonAPITestCase::test_get_lastfunction_header_should_return_header
+ tests/test_core.py::TwythonAPITestCase::test_request_should_handle_400_for_missing_auth_data
+ tests/test_core.py::TwythonAPITestCase::test_request_should_handle_400_that_is_not_auth_related
+ tests/test_core.py::TwythonAPITestCase::test_request_should_handle_401
+ tests/test_core.py::TwythonAPITestCase::test_request_should_handle_rate_limit
+ tests/test_core.py::TwythonAPITestCase::test_sends_correct_accept_encoding_header
+)