summaryrefslogtreecommitdiff
path: root/dev-python/twython/twython-3.7.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /dev-python/twython/twython-3.7.0.ebuild
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'dev-python/twython/twython-3.7.0.ebuild')
-rw-r--r--dev-python/twython/twython-3.7.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/twython/twython-3.7.0.ebuild b/dev-python/twython/twython-3.7.0.ebuild
new file mode 100644
index 000000000000..78ec75b623aa
--- /dev/null
+++ b/dev-python/twython/twython-3.7.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="An easy way to access Twitter data with Python"
+HOMEPAGE="https://github.com/ryanmcgrath/twython"
+SRC_URI="https://github.com/ryanmcgrath/twython/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/requests-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-oauthlib-0.4.0[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( dev-python/responses[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # tests are largely broken/outdated
+ sed -e 's:test_get_lastfunction_header_should_return_header:_&:' \
+ -e 's:test_request_should_handle_4:_&:' \
+ -e 's:test_request_should_handle_rate_limit:_&:' \
+ -i tests/test_core.py || die
+
+ distutils-r1_src_prepare
+}