summaryrefslogtreecommitdiff
path: root/dev-python/tweepy/tweepy-3.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/tweepy/tweepy-3.5.0.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/tweepy/tweepy-3.5.0.ebuild')
-rw-r--r--dev-python/tweepy/tweepy-3.5.0.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/tweepy/tweepy-3.5.0.ebuild b/dev-python/tweepy/tweepy-3.5.0.ebuild
deleted file mode 100644
index 8a4aa583abb8..000000000000
--- a/dev-python/tweepy/tweepy-3.5.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-PYTHON_REQ_USE="ssl(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="A Python library for accessing the Twitter API "
-HOMEPAGE="https://www.tweepy.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples test"
-
-RESTRICT="test" #missing in tarball
-
-DEPEND="
- dev-python/pip[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
- "
-RDEPEND="
- >=dev-python/requests-2.4.3[${PYTHON_USEDEP}]
- >=dev-python/requests-oauthlib-0.4.1[${PYTHON_USEDEP}]
- >=dev-python/six-1.7.3[${PYTHON_USEDEP}]
-"
-python_prepare_all() {
- # Required to avoid file collisions at install
- sed \
- -e "/find_packages/s:]:,'tests.*','examples']:g" \
- -i setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- nosetests -v -c tests/travis-tests.cfg || die
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-}