summaryrefslogtreecommitdiff
path: root/dev-python/tweedledum
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-15 07:41:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-15 07:41:50 +0100
commitb3f2504c1d05b5999b74b2135860fc721e3adf68 (patch)
treee11656067365c7d474553833d6202ed04d3324a5 /dev-python/tweedledum
parente0fdb8199de0e7a9b7c72d7f38d2e3ddaecdacd0 (diff)
gentoo auto-resync : 15:07:2022 - 07:41:50
Diffstat (limited to 'dev-python/tweedledum')
-rw-r--r--dev-python/tweedledum/Manifest3
-rw-r--r--dev-python/tweedledum/metadata.xml20
-rw-r--r--dev-python/tweedledum/tweedledum-1.1.1.ebuild35
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/tweedledum/Manifest b/dev-python/tweedledum/Manifest
new file mode 100644
index 000000000000..24396a963770
--- /dev/null
+++ b/dev-python/tweedledum/Manifest
@@ -0,0 +1,3 @@
+DIST tweedledum-1.1.1.gh.tar.gz 5105832 BLAKE2B 71e3e9baaccc345910d5be3831ea0476b06bc3171311d17fc3f160b7d4c9026bab719b1e80f1d462183cdcc1feb750542e2649c2aab5cdc6d4551ab258866649 SHA512 eda9c0d895d59450150946d52d942174652d305a863a10bafa60300cde63a692a8105b7bb5dcc86aeb610b666945215905cf95859f3726b875c88d5cd3d34891
+EBUILD tweedledum-1.1.1.ebuild 817 BLAKE2B f02915d555215a75b6a947f4c36f3fb91a3d6e49dbe2411e67a9221ddfd24c1675653bb135de7064ba8f30d474bbddec5a074b692b563dd9405de42857b9a1fa SHA512 534f3e5d5200b2199a7d23da41815cc7c8bcd788e9c52bdb45b6f51cdfb5fbc4958abf799315e7adcf5046454986dacc4f6b00589df18f15d10d5690a2940adc
+MISC metadata.xml 923 BLAKE2B 4823b5eaf8aa244a393deb861164a72b9f3e6123e7c1b45e27f268f4abc2ebd6e6530eaa7a023a503e85acdd38478bb01d6a518650c0f8b3187ed7fe6337a21a SHA512 a54737fde64a8e343eb5de58a5f8eccdae8eae4d268c35cf4a576838ccf54d554f6842db7ae44e686e0cc93905d63b7de46bced809fcd648cee91bd65fe0f801
diff --git a/dev-python/tweedledum/metadata.xml b/dev-python/tweedledum/metadata.xml
new file mode 100644
index 000000000000..b68d63379f25
--- /dev/null
+++ b/dev-python/tweedledum/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- comaintainers-welcomed -->
+ <maintainer type="person" proxied="yes">
+ <email>gaboroszkar@protonmail.com</email>
+ <name>Gábor Oszkár Dénes</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ tweedledum is a library for synthesis, compilation, and optimization of quantum circuits. The library is written to be scalable up to problem sizes in which quantum circuits outperform classical ones. Also, it is meant to be used both independently and alongside established tools.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">boschmitt/tweedledum</remote-id>
+ <remote-id type="pypi">tweedledum</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/tweedledum/tweedledum-1.1.1.ebuild b/dev-python/tweedledum/tweedledum-1.1.1.ebuild
new file mode 100644
index 000000000000..392e1dd17b22
--- /dev/null
+++ b/dev-python/tweedledum/tweedledum-1.1.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for analysis, compilation, synthesis, optimization of quantum circuits"
+HOMEPAGE="https://github.com/boschmitt/tweedledum"
+SRC_URI="https://github.com/boschmitt/tweedledum/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# >=dev-python/setuptools-42.0.0
+# >=dev-python/wheel
+# dev-util/ninja
+BDEPEND="
+ >=dev-util/cmake-3.18
+ >=dev-python/scikit-build-0.12.0"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ local -x SKBUILD_CONFIGURE_OPTIONS="-DCMAKE_BUILD_TYPE=RelWithDebInfo"
+ distutils-r1_python_compile
+}
+
+python_test() {
+ epytest python/test
+}