summaryrefslogtreecommitdiff
path: root/dev-python/tweedledum/tweedledum-1.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-15 07:41:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-15 07:41:50 +0100
commitb3f2504c1d05b5999b74b2135860fc721e3adf68 (patch)
treee11656067365c7d474553833d6202ed04d3324a5 /dev-python/tweedledum/tweedledum-1.1.1.ebuild
parente0fdb8199de0e7a9b7c72d7f38d2e3ddaecdacd0 (diff)
gentoo auto-resync : 15:07:2022 - 07:41:50
Diffstat (limited to 'dev-python/tweedledum/tweedledum-1.1.1.ebuild')
-rw-r--r--dev-python/tweedledum/tweedledum-1.1.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/tweedledum/tweedledum-1.1.1.ebuild b/dev-python/tweedledum/tweedledum-1.1.1.ebuild
new file mode 100644
index 000000000000..392e1dd17b22
--- /dev/null
+++ b/dev-python/tweedledum/tweedledum-1.1.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for analysis, compilation, synthesis, optimization of quantum circuits"
+HOMEPAGE="https://github.com/boschmitt/tweedledum"
+SRC_URI="https://github.com/boschmitt/tweedledum/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# >=dev-python/setuptools-42.0.0
+# >=dev-python/wheel
+# dev-util/ninja
+BDEPEND="
+ >=dev-util/cmake-3.18
+ >=dev-python/scikit-build-0.12.0"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ local -x SKBUILD_CONFIGURE_OPTIONS="-DCMAKE_BUILD_TYPE=RelWithDebInfo"
+ distutils-r1_python_compile
+}
+
+python_test() {
+ epytest python/test
+}