summaryrefslogtreecommitdiff
path: root/dev-python/ttystatus
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-14 11:04:34 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-14 11:04:34 +0100
commitdd762ff83c330186ee2ede002e08b2f780cddd51 (patch)
tree63198edcc3ad5df8e2566c28ff9bd8af50cc2174 /dev-python/ttystatus
parent51af5f0eb4cddbe6aa7953717873691d77aae9ff (diff)
gentoo resync : 14.07.2019
Diffstat (limited to 'dev-python/ttystatus')
-rw-r--r--dev-python/ttystatus/Manifest2
-rw-r--r--dev-python/ttystatus/ttystatus-0.36.ebuild22
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/ttystatus/Manifest b/dev-python/ttystatus/Manifest
index acb55a9055fd..0cc9dd32275d 100644
--- a/dev-python/ttystatus/Manifest
+++ b/dev-python/ttystatus/Manifest
@@ -1,3 +1,5 @@
DIST ttystatus-0.35.tar.gz 34144 BLAKE2B 92a11676525f2db5b3bc09786ddb3651f72202eaf9edf872faa5b5cbe7c01a64bb904fa92538ddfd15e7a077b4648bb02c0ac5a60fdbee105ef2789686d6c405 SHA512 5c2b1306bb1025dbbc78b53faca3ed07b21fec6a7084517f6b58c3e195fc8a901ed71b62429af2261850e819b52a08e3b3bf3def61b06c9a9451af02f4f2dddf
+DIST ttystatus-0.36.tar.gz 30766 BLAKE2B 4fbb298a86472305a01ed7a8a41cbbea3f0e1677c8f5b349e71631d3474a59cbd65d114f55ad64339804ecb97bfc3e745cd93d09bc110c2c32f53404f898ecd8 SHA512 0005d18834eca702e4c96ab85216e3bb06fadf58555641405b2657b9f296b750d1084947d1a39c4e2c0bf0711ff859df06f1e859d6e82af41d2945e980529dcc
EBUILD ttystatus-0.35.ebuild 546 BLAKE2B c8e695b3a7d4780814cdb70a3fe01fb5fb38380b1fe44de1fd73713774f1a3a957cc73027c07cf842e1bb1a92a94f34ff160713a4d3c823f360bc3ff9a884e21 SHA512 3f59da4728fd460e8b04e0871977117ecf378409b19bf89e30bff766037a92fbd13448eb25688b3abe69f8e3bbfee31983074180de0785652c6c0d876c06d5fd
+EBUILD ttystatus-0.36.ebuild 574 BLAKE2B 89e56a01b73a4712795f41457c3251b29c8462d365e6b1cc0063b5d55abcf5ab040d1564c3bc8f744e85609912218bea1676082243089dc5702416cf1a639622 SHA512 b48506b30ce53adb302290ea8073d1267a93262890cdfa809cd614f14bffcdd95ac5e6b807a2c48f23a6882893c8ed579775036560b7b4e9ed84c1365a71f99e
MISC metadata.xml 167 BLAKE2B e4dadf27fd344484f2bccb5b904909c89aac568c32e5b3c44bdf139eacefd4b4fae74419f503d2b7da0dccc1b68ba05d777d11292c0f89270d1ac5c9c703e8ca SHA512 7c8decb24ee3a850e38186cf3c7f8933a28017426806870ad6ef9ceb2533be147a2681fc789b535a81cb528af8c29d90d3006e4f250aee23bd7dea4561294e33
diff --git a/dev-python/ttystatus/ttystatus-0.36.ebuild b/dev-python/ttystatus/ttystatus-0.36.ebuild
new file mode 100644
index 000000000000..6251a3e1cb9b
--- /dev/null
+++ b/dev-python/ttystatus/ttystatus-0.36.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+PYTHON_REQ_USE="ncurses"
+
+inherit distutils-r1
+
+DESCRIPTION="Terminal progress bar and status output for command line"
+HOMEPAGE="https://liw.fi/ttystatus/"
+SRC_URI="http://git.liw.fi/${PN}/snapshot/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+IUSE=""
+
+python_test() {
+ "${EPYTHON}" -m unittest discover -v -p '*_tests.py' || die
+}